Anyone know of a Script Maker App for Mac OSX?

@559lawndart
I am not sure how to use your solution. If you have time could you post a few more details / commands to run/install. Thanks.

Wow thank you @Mongoose this is actually working!

Now we just need the motion tracking to work as well :slight_smile:

1 Like

It’s not finding the mpv headers, which to me seems like perhaps you’ve missed switching into x86 Rosetta2 mode and installing homebrew again while pretending to be an Intel machine?

Try the following in a Terminal:

arch -x86_64 /bin/bash
[opens a new fake-Intel bash shell]

in the new fake-Intel shell, we want to nstall the Intel version of Homebrew:
arch -x86_64 /bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

Still in the fake-Intel shell, we now want to install the Intel-homebrew version of mpv (and its libraries & headers), which should fix your missing file issue. We’ll call the Intel version of homebrew directly, just to make sure:
/usr/local/Homebrew/bin/brew install mpv

Now, still in the fake-Intel shell, run the rest of the compilation. This will build the Intel version of OpenFunscripter, which is ok because it’ll run fine through Rosetta2 (and the ARM-native version fails to build anyway):
cd ~/OpenFunscripter
cmake -B build
cd build
make

Hope that works for you!

I did exactly as you said, and got the same error.

When it gives the error I was running /usr/local/Homebrew/bin/brew reinstall mpv in the arch -x86_64 /bin/bash terminal.

When I opened a new terminal and ran /usr/local/Homebrew/bin/brew reinstall mpv ,
then the compile worked fine, and I can now open the app.

Thanks for the help, now to learn how to write a script in the app.

1 Like

Oh interesting, thanks for the heads up. Glad to hear you got it working!

Gonna try to get this working after xcode downloads however I have very little experience building anything so we will see how it goes. I am excited if I can get it working so I can help contribute here.

1 Like

The instructions above do work but I noticed I couldn’t use the VR display mode. I can choose the left or right side, so you can still script with it.

For 2D it works great though, albeit without the motion tracker.

Getting the same error as mentioned above about the headers. I followed your response to sml and got brew is installed and already up to date. I tried using the brew reinstall mvp and get it again after the make command…
I tried sml’s way and I get

Error: Cannot install in Homebrew on ARM processor in Intel default prefix (/usr/local)!

Please create a new installation in /opt/homebrew using one of the

"Alternative Installs

Help please lol.

Thanks, @559lawndart and @Mongoose - I now have a fully functional version of OFS on my personal dev laptop. My wife will be happy to have one less machine sitting around in the living room.

1 Like

On a Mac with M1 chip:

I have OpenFunscripter 1.4.4 compiled and working.

Questions:

  1. I copied some lua scripts into my lua directory, they do not show up in the tool “custom functions”.

I tried putting them here:
/Users/me/OpenFunscripter/bin/OpenFunscripter.app/Contents/Resources/data/lua
and here:
/Users/me/OpenFunscripter/data/lua

but neither location results in them showing up in OFS.

Neither “script directory” or “reload scripts” buttons do anything (maybe just work on windows).

  1. Not really important to me, but watching the tutorial videos, I noticed when I right click on the waveform, I get “scripts / rendering / waveform”, I do not have the audio, i.e. “scripts / rendering / audio waveform” option.

  2. Most important, has anyone managed to have the motion tracking working on a mac with M1 chip.
    I have run the linux setup script, after a couple other updates it seems to have run ok,
    ls ~/.local/share/OFS/OFS_data/extensions/MTFG/Python-Funscript-Editor/contrib/Installer/assets/
    README.md json.lua libcrypto-1_1-x64.dll libssl-1_1-x64.dll main.lua

This was all the script needed to run error free,
brew install coreutils (gave me realpath, needed by openfunscripter_setup_linux.sh)

  1. Assuming you’re running OFS from macOS’s main Applications folder (/Applications/OpenFunscripter.app), you’ll want to put your Lua scripts inside that app. In the Finder, go to /Applications. Right-click/Ctl-click on the OpenFunscripter app and choose “Show Package Contents”, open Contents > Resources > data > lua and put your scripts here, then they’ll work. The full path to that folder will be /Applications/OpenFunscripter.app/Contents/Resources/data/lua so you were almost right, but you’re probably running the app from the /Applications folder rather than your bin build folder. Just make sure if you rebuild or upgrade the app that you copy all your scripts over to the new app before deleting the old app, otherwise you’ll lose your scripts. (It’s not really the “right” place to put them, in that the “more correct for macOS” location should be ~/Library/Application Support/OFS/OFS_data/lua or something like that, but I’m not sure if that works. Back when I checked it all the thing that was causing the app to crash on launch was those internal folder locations, so I didn’t really check much further.)

  2. Yeah the waveform doesn’t seem to render for me either in the Mac build. Unfortunately I’m not sure how to fix this for now, my C++ skills are weak.

  3. Alas no luck here either with the motion tracking on an M1, I gave up after an hour or two myself. I got the Python app built and running (with no bounding boxes tho) but the Linux scripts didn’t seem to put the extra things in the right places, if I remember correctly? I’ll try to take another run at it now that it’s had a few updates, see if I can figure how to get it talking to OFS correctly.

By the by, this will attempt to install Xcode Command Line tools. If you are using an older version of MacOS, the current version is incompatible. It won’t install it, but it won’t give you an understandable error, either, it will just time out. To get it for Big Sur, you can sign into Apple Developer Tools at this link:

You can use your existing AppleID but it will ask you to agree to the Developer T&C. Once you do that, you can use this link:

(Add https:// to the beginning and take out the spaces) download.developer.apple.com / Developer_Tools / Command_Line_Tools_for_Xcode_12.5.1 / Command_Line_Tools_for_Xcode_12.5.1.dmg

to get a .dmg that has the tools. Install them, and then the git command will work.

1 Like

Everyone who have issues with client.h try this:

cp -r lib/libmpv/include/mpv OFS-lib/

Also for those who use ports. You need to install mpv this way:

sudo port install mpv +libmpv

And then

sudo ln -s /opt/local/lib/libmpv.1.109.0.dylib /usr/local/lib/libmpv.dylib