Heresphere and Scriptplayer/multifunplayer Failed Connection

I followed Husky’s guide to connect my Keon and Quest 2. After getting everything done and searching the forums I still can’t get Heresphere to connect to either scriptplayer or multifunplayer.
On scriptplayer I get the error "DeoVR not connected. Open settings mentu in selection scene or file browser. Toggle switch ‘Enable remote control’. And on heresphere I get the error below. I got the quest and pc on the same network, and toggled the hell out of the heresphere server enabled. I tried the oculus IP as well as a different IP. I’m about to throw the quest out at this point.

HereSphere failed with exception:

System.Net.Sockets.SocketException (10061): No connection could be made because the target machine actively refused it.
at System.Net.Sockets.Socket.AwaitableSocketAsyncEventArgs.ThrowException(SocketError error, CancellationToken cancellationToken)
at System.Net.Sockets.Socket.AwaitableSocketAsyncEventArgs.System.Threading.Tasks.Sources.IValueTaskSource.GetResult(Int16 token)
at System.Net.Sockets.Socket.g__WaitForConnectWithCancellation|281_0(AwaitableSocketAsyncEventArgs saea, ValueTask connectTask, CancellationToken cancellationToken)
at System.Net.Sockets.TcpClient.CompleteConnectAsync(ValueTask task)
at MultiFunPlayer.MediaSource.ViewModels.HereSphereMediaSourceViewModel.RunAsync(CancellationToken token)

1 Like

I also have this exact problem. Did you get it figured out?

I dont use my devices often, maybe its some sort of update to heresphere?

I get the same thing on multifunplayer. Any fix?

You need to enable remote control in DeoVR/HereSphere settings then enter Quest IP as endpoint in MFP.
If the same error still pops up then there might be an issue with your networking. Check firewall or if you can ping the Quest.

I’m getting the same error. I pinged the quest and got 4/4 recieved and made the allowance through the firewall (I turned the damn thing off too just to be sure).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.