MultiFunPlayer v1.21.0 - Multi axis funscript player - Now with SLR Interactive support

Hello It would be nice to be able to login to SLR to stream the scripts on OSR2/SR6 AND to another Lovense device simultaneously (hush2/edge2) … Is it possible ?

Thanks

Yup, you can do that no problem. You can even use all four at the same time if you want. SLR scripts work no different than normal scripts so you can test the setup with normal scripts.

You add one network/serial output for osr and a buttplug output for the vibe, and then map the vibe to L0.
But you will probably want to do something like this: MultiFunPlayer v1.21.0 - Multi axis funscript player - Now with SLR Interactive support - #241 by Maryjay

Please note that some users reported problems with DeoVR on oculus quest crashing after its latest update when trying to connect MultiFunPlayer. The fix for now seems to be to disable “Android Overlay (BETA)” in DeoVR settings.

How do I get the user configurable smart limit to have multiple nodes like you show in the example? I clicked around and could only get one value node so it behaves like a global limit instead of having different limits at different L0 values.

Also, could you make it so that the Motion Provider movements provide values that these limits respond to, and that can be linked to. I tried this and when using the Motion Provider on L0, I could not get the R2 axis to respond via linking. Let me know if I’m missing something.

I want to be able to have the L0 axis movements that are randomly generated link to the R2 pitch axis so that at the top of the stroke, the R2 can pitch forward in a “twerk” move, but the bottom, it won’t twerk quite as hard and bend my anatomy. If this could work with linking, but also with randomly generated moves, that’d be great!

The idea is that the moves can gyrate around more at the top of the L0 axis, but are more constrained at the bottom, so having the same kind of linking/limiting ability on the R1 roll axis would be great, too.

I play in VAM and use this to create movements of the characters in a scene. Is there a way to get VAM to trigger Motion Provider parameter changes so that from within a VR CGI scene, one could request faster strokes, or a change of looping scripts, and the command would increase the speed/change the script of the L0 axis?

I had that problem and fixed it by uninstalling and reinstalling DeoVR in my Quest 2.

1 Like

Double click on empty space to add new nodes, double click on node to remove it.

Smart limit input value is the final calculated value that combines script, motion provider and other features. You dont have to link axes for smart limit to work, linking is for script only, basically when you link axes the script is copied to the other one.
You have to set “Input axis” in the smart limit for R1/R2 to L0.

Not really what it was designed for but this should work:

  • Random motion provider on L0
  • On R1/R2:
    • Set motion provider to “pattern”
    • Set motion provider range to 99%-100% or 0%-1% depending on what you want (both handles max right or max left), this will limit it to constant 0% or 100% value. Or set it to some specific value you want like 59%-60%.
    • Set smart limit input axis to L0
    • Configure smart limit curve to your liking

Its simpler to create “grinding” behavior with scripts:

  • Link R2 to L0
  • Add slight script offset, for example 0.5s
  • Optionally invert R2 script

Yea that was more or less the idea behind smart limit, just inverted: less movement at the top, more at the bottom.

Only via keyboard/mouse/gamepad keybinds, there is no vam → mfp communication.

1 Like

Slowly getting there ! Your software is awesome I wonder why it took me so long to try it properly _
Last problem to solve : I have OSR2 (serial output) and lovense toy (buttplug) all configured properly as you just suggested. Everything work except that the Lovense still vibrates at its lowest setting when (V0) shows zero.

Is there a way to make it really zero (no vibes at all) ?

Thanks for your support

It should do that yes.
Make sure you have minimum V0 output range in buttplug output set to 0%.

Otherwise you would have to change log level to trace via the cog button at the top, reproduce it not stopping at 0%, and send me the latest log file.

Hello,
need help for quest 2 with Multifunplayer. connect to Buttplug not to Heresphere (Quest) Ip from Quest access denied. Can anyone help why?
thx

Make sure to enable remote control in HereSphere settings, also the ip in MFP also needs to include the port: <ip>:23554.

Added initial The Handy output that uses V3 firmware: nightly.link | Repository Yoooi0/MultiFunPlayer | Run #2703641936
Absolutely not tested as I dont have a handy so I would appreciate if anyone could report any issues.

1 Like

Is there any know issue with Windows 11?
I can open MultiFunPlayer-1.20.2 without any issues. MultiFunPlayer-1.21.0 doesn’t open. No dialog appears, no log folder. :cry:
Any ideas?

Try installing latest .net x64 desktop runtime: Download .NET 6.0 Runtime
As usual it seems microsoft broke update popups because it should tell you that you need to update and auto download/install it.

On github there are also “self contained” releases that you can download which dont require .net installation.

Thanks. That did the trick. :+1: