MultiFunPlayer v1.25.2 - Multi axis funscript player - Now with SLR Interactive support

Yup, tho I’m not sure if/which firmware supports it.
You can activate lube via a script (<videoname>.lube.funscript) or you could setup a looping motion provider with a custom script that for example is at 0% for 1 minute, then at 100% for 5seconds. I should probably add a new motion provider that lets you specify on/off time so you dont have to make a script each time.
Also make sure you have lube axis enabled in device settings.

Once I get a Tempest max device I will gladly look into this. I hate the fact that i Keep having to look under my VR headset to re-lube my launch. Also would it be any more difficult to add a second pump? I’d love for a second pump to be added. Just to add a squirt of water every now and then to loosen up the lube.

Don’t think there is a firmware with two pumps, from MFP side its not an issue but the firmware needs to read the commands and run the pumps.

From what I understand you can run more than one device at a time and have each device run on separate scripts right? For example, a lovense edge 2 can use a vibration script while at the same time your Fleshlight Launch is running a normal scripts. That’s just how its been explained to me. I haven’t tested or used the program yet. But if that’s the case I could just run a lube script for a separate device(lube pump filled with water).

Is that now how it works?

Yes you can run multiple devices at the same time.
For Serial/TCP/UDP/Websocket/Pipe outputs MFP sends all axes as TCode. So you would have to parse it on your pump device.
With buttplug output you can map specific axes to specific devices.

I was wondering how well the lovense gravity plays with funscripts… and if it was a thumbs up or down to get it… thank you for making it possible with MFP Yoooi!!

1 Like

Does the gravity work well with MFP? Like no stutters etc?
Given that I wrote the V6 buttplug library from scratch, I wonder if all the bluetooth stroke devices that had trouble before are now working fine. Like Launch/The Handy/Vorze A10 etc.

Unfortunately, handy via intiface still has stutters on mfp

Dear, what does it mean to support SLR multi-axis scripts. I can’t find their format anywhere - is there a link or is this information under a non-disclosure agreement?

SLR extended funscript format to support more axes, tho I think none are released as of now.

1 Like

Tried to set it up to work using a SMB share on HereSphere with the Handy. Got everything connected fine, I see the script playing in the app perfectly, but the handy is playing it all jittery, not smooth at all. Is it a known issue or is it fixable on my side? I’m using HereSphere demo if that matters, I wanted to see if the whole thing was working before buying.

It is a known issue as in The Handy wants you to send all communications thru their servers, which is terrible for real time motion. Their “fix” for that is to upload the whole script to the device which MFP doesnt do.
The Handy support in MFP is added as “experimantal” feature. You could maybe try lowering the update rate. Or you could try using MFP with as it communicates via bluetooth.
Otherwise you have to use some other player that uploads the whole script to the device, and loose like 95% of MFP features.

I set it up with and it’s still jittery, a little but better, but still pretty bad. I also lowered the update rate to the minimum (5hz). Is there something else to try?

Yeah… I dunno. At 200ms between commands it should not jitter at all, so no idea.
The problem is I dont have the handy to test, so there is a chance its an issue with MFP but I dont think so.
If you know programming/C# you could debug it.

What’s strange is that The Handy connected via on ScriptPlayer doesn’t jitter for me. I’ve tried to take a look at the source code of both SP and MFP, but I’m not too familiar with C# nor the buttplug API, and the API was implemented very differently between both, so it’s hard for me to say what causes the different behaviour.

Also i’ve figured out a bit of a jank work around. I have both MFP and SP connect to MPC-HC and connect my Handy directly to SP, and my vibrators connected to MFP via

Hey @Yoooi - first thanks so much for all the work here. This is amazing. Was struggling to get DeoVR to work through SLR credentials. I have DeoVR running on my Quest 2 and I am logged in, but MFP is telling me that it cant find a running DeoVR process. Is this not supported in this way?

In MFP you need to expand DeoVR settings and set the endpoint ip to your quest ip.