Can't Connect TheHandy to Wifi

I’ve followed TheHandy tutorial video on YouTube exactly. Password is correct. I’m using the Oculus Go. I’m able to setup TheHandy as it’s own Wifi network in the Oculus Wifi settings, but once I click on TheHandy network and it takes me to TheHandy setup page, I click to Setup Wifi and it won’t recognize TheHandy. Fails every time, then webpage seems to disconnect from the internet and no longer work unless I close it and come back on a new page.

Tried to download the Firmware update just to see if an update may offer a fix. No dice. Firmware download fails.

In short, I can get as far as the turquoise and blue LED lights (Setup ready stage) on this page (under " Relevant LED indicator codes"):

Can you try setting up the Handy on a desktop browser? Or smartphone. I’ve never heard of anyone using the Oculus browser to set it up so that could be the issue.

Also, to be clear, once it’s set up, the Go doesn’t connect directly to the Handy. Both should be connected to your WiFi router and they communicate via Handy’s servers in the cloud.

I had to change my Wifi SSID and password to something simpler. I used to have a 32 character long password with a lot of special characters which I replaced with 16 chars alphanumeric- suddenly it worked

I get exact the same problem using a smartphone :frowning:

My password is alphanumeric. 13 characters, none special. Still, no luck. It’s communicating with the connection since following through the Handy’s setup site causes the lights to indicate differently, but it won’t fully connect.

Every time I click on the Handy wifi network on my phone, it goes to the Handy setup page but just as it does it a black and white popup message (white text on black bar) says “The internet is unavailable with Handy setup - (then a short series of random characters)”

On the page it says in a yellow box: “Failed to connect to (insert wifi network name). Sorry for the inconvenience, but please perform the WiFi setup again.”

Under that is a button that says “Setup wifi”. I click that. It scans for networks. I select my home wifi network. I enter my wifi password. I hit connect. It scans. It fails: Handy light goes to the blue-red sequence indicating failure to connect.

Okay, so I got the Handy to connect to my wifi, and I also was able to download the firmware update. I just had to refresh everything, shut it all down, and let it sit for about 10 minutes. That did the trick.

However, I still can’t connect to I’ve even gotten a new key and it just hangs in searching phase. I’ve tried through my phone and my PC browser. Won’t connect.

Nevermind. I figured it out. You just have to restart Handy and give the wifi button a single press, then connect to with your key. Maybe I missed that in the instructions?

Now I just have to play with the sync functions. Video and Handy seems off timing.

@MysteryMan the keys and control can be a bit confusing at the beginning IMHO, i mean the whole wifi on/off thing.

1 Like

One thing the webpage needs is a way to store your key, because when it times out and erases it while you still have your headset on or your Handy ready and “in place” it’s an awkward, fumbling exercise.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.