EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

Cant Get Kiiro Onyx+ Realm Edition to Work on PC Bluetooth Script Player and Intiface

So I was unable to connect my Kiiro Onyx + Realm Edition to my PC Bluetooth which has BLE built in. No matter what I tried when searching for devices in script player, consistently no devices were showing. It took me about 3 days to figure out the simple solution required.

Decided to post here so others with the same issue wont waste as much time trying to figure out a workaround.

So I noticed that in my PC bluetooth my ONXY+ Realm was showing as Realm1.1.
Basically the name of the bluetooth incoming connection was different that what initface/script player was looking for which is “Onyx+”

To remedy I had to manually edit the buttplug-device-config.json, which is found in the folder directory Users:your username:AppData:local:intiface desktop

Don’t be intimidated by changing this, you only have to change two names within this file.

Open the json file with notepad and if you scroll down halfway you will see the following lines.

“kiiroo-v21-initialized”: {
“btle”: {
“names”: [
“Rey”,
“We-Vibe Rocketman”,
“Onyx2.1”,
“Onyx+”
“KEON”
],
“services”: {
“00001900-0000-1000-8000-00805f9b34fb”: {
“whitelist”: “00001901-0000-1000-8000-00805f9b34fb”,
“tx”: “00001902-0000-1000-8000-00805f9b34fb”,
“rx”: “00001903-0000-1000-8000-00805f9b34fb”
}
}
},
“defaults”: {
“name”: {
“en-us”: “Kiiroo V2.1 Initialized Device”
},
“messages”: {}
},
“configurations”: [
{
“identifier”: [
“Onyx2.1”
],
“name”: {
“en-us”: “Kiiroo Onyx 2.1”
},
“messages”: {
“LinearCmd”: {
“FeatureCount”: 1,
“StepCount”: [
99
]
},
“FleshlightLaunchFW12Cmd”: {}
}
},
{
“identifier”: [
“Onyx+”
],
“name”: {
“en-us”: “Kiiroo Onyx+”
},
“messages”: {
“LinearCmd”: {
“FeatureCount”: 1,
“StepCount”: [
99
]
},
“FleshlightLaunchFW12Cmd”: {}

for this you need to change where it says Onyx+ to the same name as your onyx realm is showing as in the bluetooth settings of your PC, for me it was Realm1.1

there are only two places in the script above where you need to replace this name. After my changes the script looks as shown below

“kiiroo-v21-initialized”: {
“btle”: {
“names”: [
“Rey”,
“We-Vibe Rocketman”,
“Onyx2.1”,
“Realm1.1”,
“KEON”
],
“services”: {
“00001900-0000-1000-8000-00805f9b34fb”: {
“whitelist”: “00001901-0000-1000-8000-00805f9b34fb”,
“tx”: “00001902-0000-1000-8000-00805f9b34fb”,
“rx”: “00001903-0000-1000-8000-00805f9b34fb”
}
}
},
“defaults”: {
“name”: {
“en-us”: “Kiiroo V2.1 Initialized Device”
},
“messages”: {}
},
“configurations”: [
{
“identifier”: [
“Onyx2.1”
],
“name”: {
“en-us”: “Kiiroo Onyx 2.1”
},
“messages”: {
“LinearCmd”: {
“FeatureCount”: 1,
“StepCount”: [
99
]
},
“FleshlightLaunchFW12Cmd”: {}
}
},
{
“identifier”: [
“Realm1.1”
],
“name”: {
“en-us”: “Kiiroo Onyx+”
},
“messages”: {
“LinearCmd”: {
“FeatureCount”: 1,
“StepCount”: [
99

As you can see I only changed two things in both places where it previously stated Onyx+ I replaced them with Realm1.1 as this was what my PC bluetooth was showing the Onyx+ Realm edition. after replacing this text scriptplayer and intiface now search for realm1.1 for my Onxy+ device incoming bluetooth connection.

After making this change There is one other step I had to perform to make it work.
before opening intiface or scriptplayer ensure you go to your PC’s Bluetooth manager and pair directly with the Onxy Realm (realm1.1 paired)

once your pc’s built in bluetooth is connected to the onyx+ realm, then you can follow the usual process, open intiface, start server, open scriptplayer, connect to buttplug, search for devices.

Now Onyx+ will show and react as a connected device.

3 Likes