Connecting the OSR2+

Hi, didnt know where to put this, so hope its ok here.
I have recently purchased a OSR2+.
I have downloaded the multifunplayer and believe I have figured it out, however, I am not sure how to connect the OSR2+. I have downloaded the CP210x-Universal-Windows-Driver.
Is this right or am I doing something wrong.
Thanks to all.

Edit: I found the on / off switch! However while the device moves slightly when turned on and the fans are going. When I play a video with the scripts, the OSR2+ still doesnt move, it will maybe twitch occasionally.
Any help would be great thanks.

I’ve never used MultiFunPlayer, but downloaded it just now to try it out and see. The copy of MPV it spawned was unable to load any video files (wouldn’t allow a drop), so I can’t confirm anything.

I suggest you find and try JoyFunPlayer, which is a lot simpler, and should just work without any fiddling.

Hi, thanks for the reply, but I still have the same problem with JoyFunPlayer. I dont know how to connect my OSR2+.

OK, so let’s get back to basics. I assume you’ve connected the top mini-USB port to your computer, right?

When you run JoyFunPlayer, does USB TCode say “Connected”?

And for a bit of background, where did you get the OSR2+? Do you have a copy of the firmware? Being able to use the Arduino interface to do basic tests would be helpful.

Yes, i have connected it to my PC, Unfortunately, it says disconnected.
I bought from mosaic (I think thats how you spell it) your hobbies customised.
Copy of the firmware? Im afraid not.
What is the Arduino interface?
Thanjs again.

Try following the steps listed here-

Thanks for this Timtom4656, unfortunately, i have alreadg seen this and followed it. I will double check the video and s ript names, but im pretty sure the only difference in name is pitch, roll etc.

Are you using the correct voltage power pack for it? What you’re describing is very similar to what I experienced when I tried a lower voltage pack than required. It would turn on, make fan sounds like it was turned on, light up like it was turned on, twitch about occasionally like it was turned on. But wouldn’t work with scripts and the such, until I got the appropriate power pack for it.

Well, its the power supply that came with it. I would have assumed it would have worked.
I did have to get a US to UK plug thing. Since im in thd UK. I will havd to look when i get home.
Thanks again.

If you’re UK, so am I, just do what I did. Buy a kettle plug and it will work a treat!

Ordered a kettle plug, should arrive tomorrow.
Will update when i can give it a try.
Thanks again.

1 Like

Unfortunatly, the kettle plug didnt work, still doing the same thin, its 5v which I believe is the right voltage.
The seriel port only shows COM1, whether or not anything is plugged in.
I guess the next thing I will try is a different USB cable.
Thanks again.

I’d recommend downloading the Arduino IDE here, installing it, then running it. It should detect the board and select the correct COM port.

If you see that it does, under Tools->Port from the main menu, then go to Tools->Serial Monitor. If you get a TCode response, you know the board is properly initialized and present. You can then send commands like “L0999S500” and “L0000S500” to raise and lower the arms slowly.

So, downloaded Arduino Interface and good news, i am connected to joyfunplayer, however, i cant open the MPV player.
Also, in MultiFunplayer COM3 has appeared, however, there is a problem connecting to the seriel port.
SO, new problems.
Thanks again.

My SR6 would not sync and twitched randomly. Eventually figured out that there was a short.

I can connect to both multifunplayer and joyfunplayer now. Thanks guys for the help.
It all works as it should.
Thanks again.