Handy stroke length (with scripts)

I’ve noticed that my handy does not go all the way up/down physically on the device, even if the script is set to 0/100%. I’ve tried handyfeeling video player, and HandyControl and made sure both are set to 100% stroke length in their settings, but on the physical device it’s more like 20-80%.

I tried clicking the increase stroke length button on the handy during a script, but it literally bricked my device and I had to downgrade/reflash to fw v3.3 to get it working again.

Is there something extra I need to do to adjust the stroke length on the physical device?

Hi, I’m not an expert, but as far as I’m concerned the stroke length depends on how the person made the script. I don’t think its guaranteed to go up or down at full length during a script, the scriptor kind of decides that as they make it.

In another sense, I kind of feel your frustration with this (if that’s the case) because I have the original Handy, and when they started doing all these firmware updates like to the 3.0s and up (I don’t know what it’s at right now) I noticed a significant change in the way it stroked. It’s much more subdued and not as fast. So I downgraded back to and are currently running on firmware 2.0 something because its much more vigorous the way I like it. Sorry if that was Irrelevant .

1 Like

I’m using my own script, which I know goes to 100%.

I found that pressing the increase stroke length button does (kind of) work, but I’m careful not to press it while a script is running. It can pretty much bottom out now, but it doesn’t seem to fully raise. Not sure, but I guess it’s good enough.

1 Like

I don’t know what went wrong on your button press but usually it works without bricking your device.

Setting the stroke length on handyfeeling to 100% is the way to go after update from FW2 to FW3.

After that you should be able to do it with multiple button presses on the device and it should even keep your settings after you powered it off.

To determine your max stroke length just test it in manual mode. (green LED)

Current FW is 3.2.3 and I wouldn’t suggest to use FW2 anymore. Newer firmwares do have many advantages and I even say that you’ll be able to feel more detail. Also strokes are a bit faster.

1 Like

Welp, it just bricked again… Maybe my device is defective.

That’s strange. What do you mean by bricked? What is your device doing / showing?

It gets stuck in the ‘Calibration’ phase on initial boot. Powering down, pressing all the buttons does nothing. Removing the strap, manually moving the slider, nothing works.

So I just was flashing it back to FW2 with the Wifi-hotspot method, and it was refusing to connect to the hotspot. And now I just powered it on to see what would happen and it fixed itself magically. This thing is acting weird…

It could work by powering the device off, then manually moving the slider all the way to the top and then powering it on again. If that’s not working, and indeed it sounds like a issue rn, you should contact Handy support either on their Discord or write them a mail. You can find the contact information on their website. They’re usually pretty accommodating.

So it happened again, and I tried your advice and it did not work.

What did work was putting it in debug mode, then restarting and it works like normal. IDK what’s going on but at least I found a way to (hopefully) consistently fix it.

Hi, thanks for the info. Do you really think the strokes are faster now with the current FW? I just know that, initially when they first went from FW2 to FW3, like last year or whenever they did that, it changed the way the handy performed. It wouldn’t make a complete up and down stroke and it was slower while watching scripts. It was really frustrating, and I actually wrote them an email, and someone replied. Anyway, I ended up downgrading to back to FW2 and it’s been fine ever since. The thing zipps up and down really fast even with all these newer scripts coming out that like shake and vibrate. I’m worried that if I update it again it won’t be the same. And I think I read somewhere there’s no going back to FW2 anymore.

There were some issues with the earlier firmwares, yeah.

Use this page to update: Update - HandyFeeling

It could be that you need it to update twice. Last time I did that from FW2 it upgraded me to 3.2.2 (it even said something like Update failed) and then I just clicked update again to get to 3.2.3

Everything should work from there on. It should be set to 100% stroke length automatically but you can still set it to 100% manually on handyfeeling.com with an extra click to be sure it’s not limited.

You can still go back to FW2 if you don’t like it, but I don’t recommend it due to the tweaks that happened over time.

1 Like