Has anyone got Initface Desktop working with WINE? (Linux)

Initiface Desktop works on Linux for native apps, but I can’t get any apps that run through WINE to connect to it. I’ve tried running the Windows version of Initiface too but it doesn’t work correctly (constant errors when starting server)

Has anyone succeeded (or gotten close) to having apps running through WINE detect the Initiface server?

1 Like

Do you get any errors when trying to connect an application that runs under WINE to the native version of Intiface? IIRC it just uses TCP/IP.

I don’t seem to get any errors, but the WINE application doesn’t seem to know the server exists/it never connects. I was able to get native Linux apps to connect, so things do seem to be working.

1 Like

I’d like to hear about any success with funscripts on Linux, with or without wine.

Which native linux apps did you get to connect?

I haven’t tested a ton of apps, but the one’s I have are;
Buttplug/Initiface web tutorial
RPG Maker Buttplug plugin
and the Minecraft Buttplug plugin

I don’t actually own a device yet, so I’m only testing if they connect to the Initiface server.
I tested an RPG Maker game I put together myself, the native Linux export of it connected to the server, but the Windows export under WINE didn’t - so I’ve 100% confirmed the issue to be with something WINE is doing. After digging around a bit it seems like WINE supports everything Initiface may need, so I’m at a loss as to what to do or try to make things work.

1 Like

Update: I got some WINE apps to work! They now successfully connect to the native Linux initiface server!!

I tested out multiple WINE versions and one that worked for me is named “w3c-6.19”. I believe more versions work than just this one, so try out a few yourself.
You need to install the dotnet48 dependency for the connection to work. More might be required, but this single dependency made things work for me. If it ends up not working after installing it, try install vcredist too.

I’ve only tested two apps so far, one works, the other doesn’t. The one that doesn’t work crashes when it tries to execute the “InitfaceCLI.exe” file - I think this can be fixed, so if any devs are watching and want an error log, let me know. It’s not all that informative however.

The other app did work, and that was the RPG Maker buttplug plugin.

I’m going to test out some more apps, if I discover anything interesting I’ll post it here.

1 Like

For the game that didn’t work, it was using Unity with buttplug-unity, the issue comes from the game trying to start its own server via that, which isn’t supported. Does any one know if you can somehow modify it so that instead of starting a server, it connects to a server?

Also, it seems like a lot of WINE versions work, however none of the GE builds worked for me.