How to stream '2d' files and scripts to Quest 2 using Heresphere?

Hi there,

Sorry if this already has an answer somewhere, I’ve tried to look but keep getting lost/ confused with everything.

I have a Quest 2 and a Handy, and so far I’ve got on well with XBVR and Heresphere to stream VR content from my Macbook with scripts attached. I’m not very tech-savvy, to get this all to work took me a few attempts, and then all of a sudden it worked.

Now my problem is, I can’t seem to get scripts to work for my ‘2d’ content. I’ve got a bunch to work on my Quest 2 by importing the files onto the actual device, but I would like to be able to access my library through Heresphere/ streaming too.

I just don’t know why my VR videos attach the script without an issue, but none of the ‘2d’ videos work at all. Does anyone have any ideas? I’ve got virtual desktop too, but that seems a bit redundant with Heresphere. I know Mac’s aren’t ideal for this sort of thing either. I appreciate any help, thanks!

1 Like

Are you able to load a custom scene for a 2d video up in XBVR? I’m not able to check right now.

Virtual desktop + script player works well. I guess I haven’t dug into it enough myself xD

2 Likes

My files are on a NAS so I use SMB (Samba) to share my files and then I bind Heresphere to the shared folder.

1 Like

XBVR only seems to work with the VR files I have. However, my Heresphere has access to my 2d videos through either the same web address link or an SMB I set up (not sure exactly?)

I use Heresphere for both 3d (VR) and 2d, why are you using two different players?

1 Like

What I love about Heresphere and the shared folder is that if you have the .funscript file aside the video in the same folder, it will upload to your handy automatically. Other players enough needs a copy of the script in your “interactive” folder of the Quest 2, which is annoying as F.

1 Like

Heresphere does work with my VR + Scripts, so does XBVR. I’m just not sure if my Heresphere is reliant upon the XBVR connection to work. I just find it odd that Heresphere allows me to play my 2d videos, but without any script working. I am running my files from an external drive through my Macbook.

Try to create a shared folder from your external HDD and add a shared folder in Heresphere. I think MAC uses SMB as shared folder protocol (I’m not really into macs)

1 Like

I’ll try this now, thanks!

Just as a precision… once you got the shared done, on the heresphere you click the “SMB network shares” top left, and you fill the fields in the middle of the screen (at the top)

  • Local IP address of your mac (should be something like 192.168.1.106 - you can find it using ifconfig in the Terminal
  • the username of your MAC account (I would suggest creating another account for the share purpose)
  • the password of your MAC account (I would suggest creating another account for the share purpose)
  • in the “path” just below the IP address, you just type the share name you gave it, no slash no bashslash
    and you hit connect
1 Like

So I’m sort of stuck at the same place I’ve been before. Sorry if this is confusing, but I’ll describe it as best as I can.

I’ve got my file ready to be shared on my Macbook from the External Drive. I have my IP address, and the SMB address. I’ve input the details into Heresphere and it tells me the connection to the SMB server failed, and that I should check the IP and SMB are online.

To test it further, I have another Macbook, which allows me to see the SMB and connect to it, however it tells me that I don’t have permission to access the server (even though I’m on the same network and they’re both my own accounts).

I’m pretty sure that XBVR is what’s letting me watch the 2d scenes, since the SMB isn’t working. Unless I need to shut my XBVR connection down to allow the SMB on Heresphere to ‘take over’ and work.

It’s so frustrating it’s so close to working but a piece of the puzzle is missing!

I have no idea what is XBVR but I don’t see why it would affect the SMB protocol/connectivity. Can you try temporarely disabling your sharing MAC firewall and see if you can connect to the SMB share?

I disconnected from XBVR, which, from what I can gather, is basically an SMB share for VR videos and scripts. There is just the added bonus that under ‘Media Sources’ in Heresphere, it shows all the 2d videos as well from the folder. All the VR scenes work fine with their scripts here, but the 2d ones don’t.

Anyway, my MAC already has it’s firewall disabled. Even more lost!

have you set permissions on the shared folder?

It’s set so that anyone can read/write with it, I don’t think I’ve done anything to it…

and what if you try mapping a drive to this same MAC, like try adding a SMB drive pointing to itself

if that works, it means this is a “user/network/firewall” issue
if it doesn’t work, it’s most likely a problem with the share itself, like the user… maybe anyone is not considered a valid user and you actually need to explicitely add a real user

I’m not entirely sure how to do the mapping thing… I’ve got my two macs in-front of me, with one being the host. Weirdly, I’ve just now seen that I can access the internal hard drives on the host mac, but not the external drive. Must be something blocking access to it?

this is a USB drive or a network drive?

USB connected external hard drive