Intiface doesn't control The Handy correctly (errors or won't find it)

I’m using onboard bluetooth from relatively high end motherboard from few years ago (X570), so it’s most likely at least 4.0, it’s on an anthenna, signal should be strong, I plug in The Handy, wait a bit, turn on bluetooth, I open bluetooth settings and Windows sees it but can’t connect to it, on the other hand I can connect handy over bluetooth via chrome on their setup (but I do not connect to wifi, reason is I don’t use wifi). I can see and change the connection key, I see handy’s mac address and firmware which is 3.2.1.

When I open intiface I start the engine/server, go into device and scan, sometimes it won’t find it at all, other times it does but I immediately get an error like “get_characteristics for GattDeviceService(IUnknown(0x2ac379ef890)) failed: Ok(GattCommunicationStatus(3))”)


Crash/error recieved but crashReporting is off, not sending to devs.

I see the “toggle oscilation” but it won’t do anything.

I managed to somehow get it to work 2 days in a row but everytime after turning it all on/off and some random order of turning on things would make it work, I can sometimes even get to the point where in the scriptplayer I’ll see message “The Handy Connected” which changes to disconnected when I turn of the bluetooth, so clearly it sees it, but even when it says connected and I see Handy in the device list with a checkmark symbol next to it (not X) it still won’t move.

Lustbound works fine everytime I try it, manual mode also does, it calibrates itself on start.

What could be the cause for these iffy connections and errors?

UPDATE (after I thought I fixed it).

Thought the new dongle (5.) fixed it but no, tried using it today again and now it won’t work, same errors like before, it sort of connects itself to intiface and via chrome on the setup page, but can’t control the device, same get_characterisitcs_async erors (0x020ec88c6280) failed: ok, gattcommunicationstatus 3.

Lustbounds doesn’t work, intiface won’t make handy move, appears in script player as a device but doesn’t move.

I also updated Intiface to latests version.

Handy is in bluetooth mode, no WIFI, Handy works on it’s own (moves, motor is good, not overheating). Dongle is 50 cm away from the handy, no other bluetooth devices nearby.

Firmware still 3.2.1+e46631cd.

Now intiface doesn’t even find the handy at all.

Steps I do:

  1. Turn Handy On
  2. Turn bluetooth on (on PC)
  3. Turn bluetooth on (on Handy)
  4. Open chrome, go to Handyverse and connect to bluetooth.
  5. Open intiface, start server, go to devices, start scanning
  6. What should happen - Handy gets found, no errors, can control it by using the toggle oscialation option and go from there with script player
    What happens: either it finds handy and gives an error, toggle oscilation doesn’t do shit or it doesn’t find it at all (at the same time Handyverse finds it, connects to it, can change the connection key and all).

Ok, there may be some issue with either handy or my bluetooth, I can still connect it over the website but now even lustbound doesn’t work.

Is it new or old. If old, did you check if it has latest firmware?

I posted my firmware, it’s basically brand new, used it maybe 4-5 times.

Ok, sorry, should have seen that.

I am running mine on a USB bluetooth 5.0. Range from antenna seems to also be important for proper signal. (Was the same with the Launch…)

The handy will not connect directly to bt like you would normally connect a bt device. It will only connect with bt through an app, which is why it works to change connection key and not in bt settings. Intiface and ScriptPlayer are what you will need to get it working if your plan is to use scripts without wifi. There are a couple of setup guides if you search. Best advice I can give is to get the “toggle oscillation” working in intiface before you setup scriptplayer. If it’s not connected and working in intiface it won’t work in scriptplayer and will just add more hours of troubleshooting.

edit: FYI - Bluetooth playing of synced scripts/video can only be done with local script/video, it will not work streaming from websites. To play scripts/video online, like from SLR, you need wifi.

1 Like

I just tried it with a dongle, 5.0, half a meter from handy, no issues anymore, looks like it may have been weak signal after all.

1 Like

That’s not what the issue was, I play locally, no wifi, 5.0 dongle fixed the issue, I think signal was too weak or my onboard bluetooth was bad.

Glad you got it working.

Damn it, it’s broken again, intiface no longer works when I toggle the oscialation, same behavior like before :angry:

While it may not be the problem, I can say that I’ve read a lot of posts saying bt 5.0 doesn’t work as well as 4.0 with the handy. I’ve used a 4.0 dongle for years with no problem. If you’ve got an old bt dongle it might be worth a try.
Here’s a link to recommendations from buttplug

Found the culprit, it’s the Handyverse and connecting The Handy to it which is preventing connection from being established with Intiface, looks like it can only be connected to one thing at a time. So if you plan on using it only locally do not connect The Handy over that site, just plug it in, enable bluetooth, go to intiface, start server and let it find your device, let the scan run if it’s first time so it detects it, then you should get no errors and clicking on toggle oscillation will make it move, click 2nd time to stop it and launch scriptplayer and it should all work from now on. Best to still use 5.0 dongle I’d say, they are cheap, have it close to the device (just in case).

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.