Kiiroo Keon

does any one know how to get the new kiiroo keon to work with pc scritps

1 Like

Hey there! Welcome to the forums! :slight_smile:

I would imagine it is the same as the Launch or a Kiiroo Onyx/2/+ where you will have to use a combination of SyncyDink, Buttplug, and ScriptPlayer to get this to work. Observe…

The easiest way is to use Buttplug and Syncydink, made by the same Buttplug team.

SYNCYDINK

  1. Head over to
    https://syncydink.buttplug.world/
  2. Follow the instructions by clicking the tab on the left. You will need Buttplug installed and started, so there is a webserver for syncydink to connect to, a video file, and a “haptics file”, or “funscript” as this is the file extension that your scripts will be. If you need to install Buttplug, read the short guide below.
  3. Connect to Buttplug in the second tab on syncydink and presto!

INSTALLING BUTTPLUG
The creators made it very easy and you just walk through a tutorial online to get this set up. To get started, go to https://tutorial.intiface.com/. Intiface is another program that they created that works with Buttplug to get the webserver started and your devices connected.

Just as a disclaimer, you will need some sort of Bluetooth dongle (not sure if the Keon connects for data transfer via usb???) with your PC, or if you have a Bluetooth networking card built into your computer, that works too (most modern laptops have it).

SCRIPTPLAYER
If you’d rather do it with just ScriptPlayer, you can do that too. You will still need Buttplug but you won’t have to use Syncydink’s website. You will be able to config your ScriptPlayer to connect with your buttplug server and therefore your devices. You can get ScriptPlayer here: Release ScriptPlayer v1.1.0 · FredTungsten/ScriptPlayer · GitHub and scroll down and download the Exe (for Windows).

SLR
Another popular option with Kiiroo devices is the SLR app, which basically is Buttplug for mobile tbh. You can get more information about that here:

Apple: https://apps.apple.com/us/app/id1502435468
Android: https://play.google.com/store/apps/details?id=com.slr.interactives&hl=en

Chat back if you have any problems! This is a very simplified set of instructions :stuck_out_tongue:

2 Likes

It’s attached in latest version intiface [Intiface Desktop | Intiface] (You must update to latest). It’s working!

@Rzes90 - Are you saying the Keon is working with Scriptplayer already? @Liquid /@qdot is this indeed correct?

Yes, it’s working now :wink: Have a nice time!

1 Like

Afaik - yes:

Really great job guys! - I cant seem to get Scriptplayer to find the Keon (while Scanning for devices and Buttplug initface connected) , but windows bluetooth sees the device fine.

@Rzes90 - did you need to do anything extra to get it to connect?

Did You update intiface? only latest version include keon.

If You have latest then try to pair keon in BT window when scriptplayer is running.

Yeah all latest updates - maybe ill try beta scriptplayer - pairs in windows BT, just nothing happens in Scriptplayer 1.1 when trying to scan

Intiface CLI RS v16 in Intiface Desktop v19? both updated?

Yes, sep14 update if thats the same one u linked iirc - Intiface Desktop | Intiface

All is good - somehow just connected on first try today when scanning - was able to test out playback and nice to see Keon is fully supported and right away usable!

Nice going @Liquid + @qdot !! :clap: :partying_face:

1 Like

Yup, it’s been in Buttplug/Initiface since mid October. I’ve got a Keon myself now too, so if anyone has issues, please let me know and I can test on my end.

1 Like

Also, wow, didn’t realize Syncydink was still a recommended app! I’m just now finishing up the new, completely rewritten version of Buttplug, hoping to port that under Syncydink soon (next few weeks), at which point the Keon should also work in Chrome directly on Desktop/Android, and in WebBLE on iOS.

I’ll try to remember to post here when that’s done, though you can also just watch the revision date on the syncydink front page.

1 Like

Hey, everyone. I have this weird issue with Keon and ScriptPlayer. When I start Intiface along with ScriptPlayer I can’t find Keon as my device in script player. I’m doing the following:

  • start Intiface and start server
  • turn on Keon (light is flashing blue - pairing mode)
  • start script player and connect it to Intiface: this works as I get a message “Connected to Buttplug”, script player is also shown in Intiface
  • but now, if I try to select Scan for devices in Script player, nothing happens

HOWEVER, if I do these, it works:

  • start Intiface and start server
  • turn on Keon (light is flashing blue - pairing mode)
  • go to https://tutorial.intiface.com/ and go through the tutorial, up to the ‘find device’ part
  • there I scan for device and keon is found and teste, now also showing up in Intiface
  • NOW when I start script player and connect to Intiface, it works. I even tried to actually play a script and Keon worked fine

Is the Script player bugged or am I missing something? I tried to reinstall my bluetooth drivers, Keon in NOT paired in windows (also tried with paired, but read somewhere that this is bad), tried reinstalling script player, and also rebooting the system. Is there a way to get Intiface to find my device without using the tutorial site?

My Intiface: v19, Intiface engine rs v20
My ScriptPlayer: v1.1.1 downloaded by using Downloading Beta Builds · FredTungsten/ScriptPlayer Wiki · GitHub

I find Keon bluetooth doesnt have the farthest range, so maybe try a usb extender cable for your bluetooth, or get it close as possible to Toy/bluetooth, since Initface (regardless of the method, should just be using your PC’s bluetooth iirc @qdot)

I often actually find myself, disconnecting Initface from Scrtipplayer and reconnecting and re-scanning a couple times if I have issues @shiningsomelier

1 Like

@Realcumber thanks for the advice. I managed to make it work somewhat but it’s still not completely smooth process. So for anyone who has same/similar issue, I can make script player find Keon by doing following:

  • in script player setting, tab ‘Buttplug’ I set Connect to Buttplug, Search for Devices to true
  • start Intiface and start server
  • now I just have to start and close script player over and over until it detects Keon, usually takes about 2-4 tries (at least in my case, distance of Keon to the bluetooth receiver didn’t seem to matter)

Not exactly ideal but it sure beat going through the tutorial every time.

@shiningsomelier - I just tested and I was able to reproduce the same issue you had:

  • Keon not being found on first attempt - So keep having Initface open, then closing Scriptplayer latest beta, then reopening Scriptplayer, connecting to buttplug and scanning devices - worked everytime on the 2nd attempt

@Liquid / @qdot - does this makes any sense why this would be happening or how to prevent?

Only if the device needs to be in some kind of “state” to be usable first.

It’s probably me. I think I broke something when trying to fix a memory leak in our bluetooth core earlier this week. I’ll try to get this patched up in the next couple of days.