EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

New VR script player

Hi guys, since SLR decided to commit suicide by limiting handy connectivity to a PAID service for your LOCAL scripts, I wonder if there is another free player able to play vr videos and scripts.
Thanks for the information :slight_smile:
Ita OK if its a bit work, but that company will NEVER see any money from me ever AGAIN!

3 Likes

I just use Scriptplayer which can plug into Whirligig/Deo without hassle. Works flawlessly with both my Estim box and my OSR2.

ScriptPlayer+HereSphere, i’m glad DeoVR started fucking around or else i wouldn’t have found that superior combo.

1 Like

HereSphere looks really interesting but 30 bucks for a video player seems pretty steep.

Edit: Just saw they have a demo. Gonna give it a go and report back.

I’ve been using the Heresphere demo for a week or so and it seems better than anything else I’ve tried. The pop-up in the demo isn’t even that annoying which is nice. The ability to adjust the ipd to scale things smaller is very easy and effective. I haven’t played around with the auto focus or movement stuff yet.

Prior to heresphere, I was using Whirligig. I have used DeoVR but never liked it.

how do you connect the scriptplayer to the Heresphere? I was only able to do it using the multifunplayer…

iirc deovr and heresphere timestamps are basically the same. if you have heresphere running, script player should recognize it as deovr.

2 Likes

I’m trying Heresphere, but I’m not able to nake it “look” like VR. Is like a big cinema Screen.

I have the issue too, that the screen moves when I’m watching it through Oculus Quest. I can lock the mouse to the screen to prevent that, but then I can’t use Quest’s controllers to control the video or the screen.

Do youo have the same issues @8ioni ??

I had an issue with the screen moving, but that was due to the headset tracking on the quest 2 being lost. Once i resolved that, it was fine. And that was affecting more than just HereSphere.

The cinema screen thing is happening with all videos? I haven’t had any issues, but it could be selecting a weird default setting. Try going to ‘Global Settings and Tools’ in the advanced video settings section and select ‘Equirectangular Preset Group’. That should work for standard VR stuff. It won’t work for SLR fisheye ones though.

If you keep having issues, you could try the HereSphere discord. They respond pretty quick and obviously have a lot more knowledge than me.

1 Like

Nope. I already had that selected.
These are the options I have. I can move the screen, approach it, or make it more or less curve, but still it’s a cinema screen.
I’m using the demo from steam, and watching it through Virtual Desktop, If it gives helps you.

Thanks a lot!!
IMG20220509190704|690x310

Looks good to me. Have you tried adding something like “_LR_180” at the end of the filename?

1 Like

Yup, right now and no difference. Cinema screen and no head tracking

how about setting aspect ratio to auto? mines usually around 1.9 iirc

Your IPD is huge. 9.0? Try manual of 6.3ish

1 Like

Might also be Virtual Desktop, Heresphere is not on the list of supported apps:

1 Like

I’ll try that too @8ioni

Thanks for the info @Husky

I’ll tell If it works

Still not works. I changed aspect ratio, and tried different ones, but still the same. It’s probably what @Husky said, unless you are using Heresphere @8ioni

do you know any good Whirligig tutorial? I’m pretty lost with that Player

Have you tried any other VR apps/games on steam via Virtual Desktop to see if they work properly? Also make sure to disable mirror mode in SteamVR to see if it breaks something.

1 Like

Gonna try it.

Also, I’m using Heresphere Demo Edition, but I don’t think this can be the problem

Shouldn’t be, demo and full version are basically the same right now.

So I checked Heresphere with my old Go and Virtual Desktop and it seems to work ok. Are you sure that you are in the VR mode when using your Quest? Would be weird if it worked on Go but not on Quest 1.

You should be able to switch between VR and desktop mode in the Virtual Desktop menu that pops up when you press one of the buttons on your controller. The options are basically named “Switch to desktop” and “Switch to VR” and you should pick up “Switch to VR” after opening Heresphere from Steam if it’s not doing it automatically.

1 Like