Nimblestroker and Scripting, a Deep Dive

Thanks! That did it, the “FleshLightLaunchFW12Cmd” was left in there and yeah I was following the mnh86 guide. Everything fully works on both Intiface Central and MFP now. Now I just need to grab a Meta Quest 3 for an easier VR setup (currently have the HP Reverb G2)

I hope this whole topic helps other future Nimble Stroker users

1 Like

Hi there, registered just to poke my head in here since info on this thing is hard to find, still. Did any of you have to do anything special with the connectivity module before uploading? I’ve gotten everything to compile and it recognizes the board, but it just flashes the encoder light a few times then declares “Wrong boot mode detected (0x13)! The chip needs to be in download mode.”

The commonly-stated remedy for this is to short IO0 to ground at reset, but I can’t access that without breaking the case open, and that feels a bit extreme. Am I missing something simple?

Hello!

My Nimble arrived last week and it’s been incredible, I’ll be writing my own review shortly.

I am having some trouble getting the connectivity module to work as I’m quite new to coding and I’m looking for some support from those above who have got it working…

I’m currently trying to install the default Nimble module from the website ( GitHub - ExploratoryDevices/NimbleConModule: Nimble Connectivity Module (Basic functions and library)) as I believe you need to load this onto the device first before then building on top of that with some of the other github repos mentioned in this thread.

I’m running into a few issues:

  1. I have installed the Arduino program, opened it and made it SP32 Dev Module in the ‘board’ settings.
  2. I then try to select Port but it’s greyed out in the program. The Gifhub website says to do the following if port is greyed out:

If, after connecting your device, no new ports are avialable in the Arduino IDE, you may need to install drivers for the USB-to-Serial capabilities of the ESP32 used in the Connectivity Module. The CP201x drivers are available on the silicon labs website. Later devices may use the CH340 USB interface. Instructions on how to install these can be found here.

Now, the issue I’m having here is that once I download the CP210x Universal Windows Driver via the website, I get a folder in my downloads with 10 random files in it with no installer. Does anyone know how to install this?

There is instructions on the website that state the following:

Install Windows Virtual COM Port (VCP) drivers

  1. Download: CP210x Universal Windows Driver from Silicon Labs (tested with v11.2.0)
  2. Extract the driver .zip file to folder
  3. Open Windows “Device Manager”
  4. Attach the NimbleConModule to the PC via the USB cable.
  5. There should be a new device listed under Other devices
  6. Select the Silicon Labs CP210x USB to UART Bride device
  7. Right-click “Properties”, navigate to “Driver” tab
  8. Click “Update Driver” → “Browse my computer for drivers”
  9. Navigate to the driver zip folder that was extracted in step 2
  10. Click Next to install.
  11. The device should now be listed in Device Manger under "Ports (COM & LPT). Make note of the COM port for future steps (ie. “COM3”).

But, the issue is, when I open Device Manager there is no ‘Other Devices’ tab leaving me stuck. Any know how to fix this?

As I was losing hope with this option it, it did state that later devices can use the CH340 USB interface which I’m trying to also download and install, however it presents the following instructions:

How to Install CH340 Drivers - How to Install CH340 Drivers - SparkFun Learn

I follow the video tutorial on the above website and I then get stuck inside of Device Manager because I don’t have a ‘Ports’ tab.

I’m simply at a dead end here because both paths I can take seem to lead me to a dead end in device manager. Is there something I’m doing wrong? Does anyone else have a simple video tutorial showing the entire process, as I imagine this is going to be a steep mountain for every non-coder to climb whenever they want to use the Nimblestroker.

Thanks for any help!

Though I’m not sure I can be of TOO much help, but my module didn’t show up in my devices list when I used the supplied USB-c cable that came with the package, had to use my own known working cable that properly detects data transfer so maybe you could try that?

You can see if you have any hidden COM ports on the Device Manager by going to View > Show Hidden Devices


This is what it looks like on my end (With my nimble on Com4 after setup)

Support got back to me re: “Wrong boot mode”, they said they’d send me the print file or another case if I had to crack it open. So I did, and plugged it in with the BOOT button held down, and it’s worked fine ever since!

I’m not having any luck getting functions to work other than L0 using NimbleTCodeSerial, though. I can get them to do things in MFP but I don’t notice anything different happening on the device.

Unfortunately, that didn’t work for me as no port option appeared.

I do have this ‘USB Serial’ under ‘Unknown devices’ which seems to be the nimble as when I unplug it, it disappears, but I honestly don’t know how to update that driver.

I’ve had my Nimble for 3 weeks now and have had zero luck with getting it to work.

Can someone create a thread with a simple installation guide as I’m getting very confused between the different things you can install onto the device as there are so many paths I can go down.

@ilfdsm2 If you’re using Windows:

I think the Silicone Labs is an older model connectivity module. The one I got recently is the CH340. Go to the site mentioned in the tutorial: https://learn.sparkfun.com/tutorials/how-to-install-ch340-drivers/all Download and install the Windows drivers. Plug your device in, it should show up under Ports (COM & LPT). If it doesn’t, try different USB ports and cables.

From my experience doing this, the problem is fucking Windows and their shitty drivers. I could never get Windows to flash the firmware for the connectivity module. I got it working in Linux and that’s how I flashed it. For some reason, Windows is really picky about the hardware. Windows works fine for using the device, but not for having to do any coding on it.

@TesterMan13 I’m extremely interested in what you had to say about using the Nimblestroker with your Handy. It sounds like attaching it to just a slightly more powerful stroking device is the optimal way to use this toy if you want to use it with funscripts. Does that sound like an accurate conclusion to you?

Has anyone tried using this yet with the SSR1, FunSR1, or the OSR2?