Nothing is working to get Passthrough working on the Quest 3

I’ve been trying for the past 4+ hours as I just got my Q3 today to get passthrough working on both Deo and Heresphere with zero luck. The background either stays black or green. Regular PT useage is fine.

My setup attempts:

  1. Windows 10 + Quest Link (wired) both Steam VR + Heresphere/Deo PT
  2. Shelled out $20 for the Virtual Desktop app on Win10 + Wireless Mode DeoVR meta store app
  3. Win10 + Virtual Desktop with SteamVR completely closed, only DeoVR meta
  4. WIn10 + Virtual Desktop + QuestLink All 3 VR players
  5. Win10 + SteamVR + Questlink + Any 3 VR players
  6. Quest 3 on its own + DeoVR Meta App, tried a free video with passthrough on home screen and still no passthrough? Toggled PT on the Quest UI and it just turns off the video feed but keeps the audio but I get regular PT.

-Boundries is enabled, since it always asks whenever I power on and hit confirm

I’ve got both chromakey and alpha videos, no matter the adjustments to color the background does not change, even though most say Alpha would just work instantly?

Nothing’s worked for my end, my brains about to explode lol

Have a passthrough compatible video (either alpha passthrough or a video with green screen)

On Quest 3:

Start video on Heresphere
Go to Advanced Settings
Look to the right at Environment
Click on the background dropbox field, choose Passthrough
Click on the mask field and choose Chromakey or Alpha Passthrough

Alpha Passthrough should immediately work if they video has “alpha” in its name and is a alpha passthrough file.



For Chroma Mask you click on the “fill” field, then a new option will open up for RBG
Click on the “fill” field for the first color, the video will open in a small video
Choose the color that you want to remove e.g. the green and just click on it


1 Like

to remove the possibility that the video is the error. just download this one because i know it works.

Open heresphere on the quest. load the video. click on the passthrough button and go to color, then color pick the background. it should work

So looks like it all boiled down to the Streamer settings in Virtual Desktop where I had to tick “Enable Passthrough” lol…

Hope this helps someone else who runs into the same problem. Now just need to figure out Virtual Desktop’s issue of their overlap and the alpha channel video causing hair to be semitransparent

1 Like

Why do you bother with Virtual Desktop at all? Just interested cause it’s not needed if you have Quest 3 and Heresphere.

oddly enough Passthrough still doesn’t work without Virtual Desktop. I only get a solid black background/green-chromakey whenever I am wired to the PC alpha PT enabled videos on Heresphere :person_shrugging:

Even enabled “Passthrough over Meta Quest Link” in the Dev tab of the Meta Quest Link app :thinking:

Why are you wired? Huh? Just SMB share your folders/files. Can’t help with wired settings (why bother with the headset being wireless?), but using Heresphere (on Quest 3) and just the files through SMB share works perfectly fine. Will take some screenshots later.

1 Like

Sideload heresphere and use a decent router (WiFi 6) and you’re set.