EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

Oculus Quest 2 DNLA buffering VR videos slow connection - other options or solutions?

I am playing downloaded 4-7K VR videos using SLR, interactive scripts and Launch by putting videos in the Oculus Quest2 256 Gb memory, this produces very good playback . I can only put about 8 - 10 movies and then it reaches maximum memory, so when I want to watch a new movie I have to delete and reload. Reloading about 200G of movies takes about an hour from the PC. I tried DNLA. I managed to connect to my PC that is connected to the router via Lan cable (1 GBps ethernet), I used 5 Ghz Wifi. I noticed that it takes a long time to load the file directory (often sometimes never), then when I play a video does buffer when changing places and occasionally stops and buffers. I also tried it using my laptop (movies on HD) connected to the router via 5 Ghz wifi and the playback is terrible, 10 seconds of buffering for 3 seconds or so of play. I am not sure if DeoVR can read files on a PC through the oculus link cable, anyone tried, or is there another way to get reasonable play back through DNLA or other method, especially on a laptop.

Are you using windows DLNA? It’s the best option.

Yes, I enabled windows 10 media streaming.

Also I have just tried option 3 of the realcucumber tutorial ( Interactive Sex Toy Scripts Complete Help Guide (Kiiroo,Launch,Vorze,The Handy) - SLR community forum for the best VR porn videos ) with no luck. I go stuck when the Deovr app on the Quest2 headset did not show “REMOTE API” in the settings menu and thus I could not go any further, I did see “remote control” and I did turn it on, I then proceeded and all worked well until I selected the Deovr player in the script player and it said “Deovr not connected” and did not provide an option to enter a IP address

As an update I fixed videos to work well on DNLA on my PC connected by LAN to the router by enabling file indexing on the drive that the folder was stored on, and I have learned a few things that got it to work, but that does not mean that there are other ways. I read these tips from many other posts (thank you) and some I discovered myself:

  1. You need to select the folder to read DNLA in Windows media player (WMP); Organise - manage libraries - video ; also some forums suggest leave WMP open on the PC.
  2. You need to enable media streaming in Windows media player ; Stream - Enable . It seems to work better when in the streaming window “customize” you PC by unticking “Use default settings” and ticking “Make all the media available to this device”
  3. When reading file from PC via DNLA, the folder/drive must be allowed for indexing, if not it will appear as “unresponsive” in the media player video “managed” libraries. Open the windows indexing options app; here are many tutorials. Sometimes when I change WIFI connections I think I need to re-enable media streaming again.
  4. The script file, to the corresponding VR movie file on the PC, must be stored on the VR goggles in the interactive folder. Must be exactly the same name.
  5. You need 5 Ghz wifi, 2.4 Ghz is too slow and buffers.
  6. Some mobile dongles have very slow streaming even at 5 ghz, connect the dongle to the laptop to provide internet via USB tethering.
  7. If using a folder hiding software like “Folder lock”, after the folder is unlocked it is not indexed because the folder appeared after bootup, it will not be indexed and if not indexed it will appear as “unresponsive” in the media player video “managed” libraries. To fix this you need to get the computer refresh the folder/drive list by restarting “Windows search” using services.msc app (truecrypt - Windows 10 (unlike Win7) keeps losing index of mounted (virtual) drive - Super User)
  8. Some laptops pause indexing when on battery power, plug in the laptop to external power. There is a way to disable this feature but I have not got it working; just plug it into power!
  9. I have a netbook that does not work even with these settings, perhaps some netbooks have an issue, but my normal laptop works well ( 8 years old, I7, 4 G ram) ? If I find out why I will update this post.
  10. Sometimes I get very erratic, unsynchronised syncing with the Launch. I make sure my PC, phone and any other Bluetooth transmitters/receivers are tuned off, turnoff Launch, restart the VR goggles, open SRL interactive app and go to the devices Tab, then turn on the Launch and let it connect, then proceed as usual.

I’m so glad I upgraded my PC and can now use Virtual Desktop instead of DLNA, works so much better! It was always very glitchy for me.