EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

Onyx+ issue with ScriptPlayer scan for devices

Hey, I’ve tried to get “part 4” of how-to-connect-your-147-sex-toys… to work with onyx+.

But I’m not managing to get ScriptPlayer connected with my onyx+, when I press “scan for devices” in script player, nothing actually happens, no error messages or anything and Onyx+ just keeps blinking (pairing mode).

My bluetooth adapter can see it via CSR (bluetooth dongle app) and is able to get paired with it (I tested with and without pairing), but it just won’t connect with ScriptPlayer.

Bluetooth adapter: Bluetooth 4.0 Nano USB Adapter
adapters driver: link

I uninstalled CSR drivers and rebooted windows, it installed generic bluetooth drivers automatically. That also didn’t help, still not working. Tested also with MultiFunPlayer but it doesn’t find Onyx+ either.

download this:

Yes, I have that one installed. The server connection works (I launch server from Intiface, and connect to it from either MultiFunPlayer or ScriptPlayer), but after creating connection with server, I’m not able to get Onyx+ connected with “Scan for devices” or with MFP “Toggle scan”.

what you have to do is connect the onyx to intiface, then disconnect from server in intiface. after that, you go to script player, go to devices, buttplug/intiface, and connect. make sure you also have the script and video loaded at the same time.

Intiface isn’t finding Onyx+ either, but I can find it with windows bluetooth if I try (and with phone).

for the onyx+ you have to pair the device with windows. It’s the only device in this case.

Hey, thanks a lot. Got it connected with that… Not sure why it didn’t work the first time I tested it. Probably had to do something with me playing around with Bluetooth services or maybe it was because of USB 3/2 ports, kept switching between them. Currently on USB 2 and it works.