Scriptplayer 1.1.1 and The Handy

So I can’t seem to make the Handy work in scriptplayer locally even though Scriptplayer says the Handy is connected.

am i missing a setting to make it work?

Prefacing that you can connect fine via HandyFeeling site correct?

It takes me 1-2 (sometimes 3) tries sometimes to get Scriptplayer to connect to my Handy, if it doesn’t work the first time I press the sync button on the handy and do Connect to Handy on Scriptplayer until the Handy is Connected message shows up

yeah works fine on handyfeeling, and i can connect it on first try in scriptplayer aswell.
But, when i play a script the handy does not move

Try the latest beta version - the Handy API changed a bit since the initial release:

@Liquid so my settings / version are as follows.

Installed Scriptplayer https://ci.appveyor.com/api/buildjobs/jf76t76jnq6o6c5u/artifacts/ScriptPlayer-Debug-1.1.1.331.exe

Settings > The Handy >

  • Connection Key: Same as on Handyfeeling

  • Script Host: Local

  • Local Settings: my computer’s IP / and port

It runs perfect using https://www.handyfeeling.com/ and instantly connects when I go to the website.

But I’d really like to use Scriptplayer instead

2 Likes

my Local Settings in the scriptplayer has nothing in the IP box and just Port 80, maybe give that a try?

image

6 Likes

Dude thanks ! this worked for me!

2 Likes

found this useful as well ty!

Glad you got it working, I had been playing with this recently and think I can clear up a bit of what is going on, so the local settings stuff is to bypass the handys servers and just send the script entirely locally, when you use the handyfeeling option you send it through their servers. The reason it wouldn’t work locally is because you actually have to have a server running to host the script, scriptplayer wont do this for you, so you need handycontrol (from another thread here). If you are running handycontrol, you can get that setup as a server, then the local settings (assuming theres no network issues blocking communication) will function and you can load scripts entirely locally without sending them back and forth through the handys servers.

I was actually perfectly happy just using the handys servers but I was trying to load a script that was almost 2 hours long and it kept failing, so that led me down this rabbit hole lol.

This is what my settings on scriptplayer/handycontrol look like…
image

3 Likes

Big thanks dude save my day

So I’m having issues with some vr videos not playing the FUNSCRIPT through scriptplayer. Scriptplayer loads the funscript and shows the heat map, but the handy won’t move on certain videos (always the same ones but they’ll work in another program - there is data on the funscripts) - does that make sense?

It’s just random ones for some reason. They are always the same ones, but I can put it in another program and it reads fine…

My issue is I use script player with whirligig on VR videos… I like whirligig - I guess I can go to DeoVR and use handycontrol - but I’d like this to work.

Anyone have any issues?

I’m new with scriptplayer and handy but I guess my problem is the same. First It’s really hard to connect the handy to script player the handy can’t connect all the time to wifi and then scriptplayer can’t always find the handy. But for some videos don’t know why it’s not working I got script player saying “Error: Machine timeout” and for others videos it’s seem to work.

I’m using handy + scriptplayer + deovr on quest 2

Can someone help us ?

It appears to be non-standard characters in the filenames that do it. It’s a recent change too it seems because these files have worked in the past.

Files with characters such as ( ) [ ] ! and others present this issue.

Digging out this old topic… Cant get scriptplayer to work with thehandy using local scripts (or online scripts).

The handy works with the local video player websites. scriptplayer loads videos (not x265 encoded files though) and also loads the funscript (heatmap is shown). Clicking on “Connect to handy directly” shows “handy connected” but nothing happens at all during video playback.

Also tried handycontrol mentioned by Nfinite and tried to configure it like shown (config screen has changed a bit). handycontrol can connected to the handy and set script player to my local ip with port 80 but again, nothing happens…

any ideas? or a step-by-step guide which version of what software is needed?

Should work when using the handyfeeling script hosting option. For whatever reason the current handy server API apparently no longer accepts local script hosting.

image

If that doesn’t help either - try using the latest beta AND the handyfeeling script host

If that isn’t the problem either - try the #techsupport channel on the official Handy discord:

1 Like

That doesn’t work either :confused: I am using ScriptPlayer v1.1.1 and latest handy firmware. Feels like I am missing a step…?

  1. Turn Handy On
  2. Switch Handy to online mode (purple light). When I now visit handyfeeling the status in the website header changes from error to connecting to connected
  3. Start Script Player
  4. Load video in Script Player (drag&drop). ScriptPlayer shows the heatmap so funscript is loaded
  5. Play video (jumping to some action but nothing happens)

I’ve reset ScriptPlayer settings and set the handy connection key as well as changing the script host to handyfeeling.com.

Just a thought, are you still connected to your handy on the Handyfeeling website? If you are then disconnect before connecting with Scriptplayer.

I tested to connect to TheHandy using Scriptplayer for the first time ever before writing this. This is what I did:

  • Turn on handy and go to online mode (purple slow flashing LED).
  • Start Scriptplayer.
  • Select Settings in the menu and select The Handy in the left pane in the Settings dialog.
  • Enter the connection key that you have generated for your TheHandy, select handyfeeling.com as Script Host. Leave local IP blank and let local port have its default value of 80 (shouldn’t be used anyway).
  • Click OK to apply the new setting.
  • Select Devices in the menu and then select Connect to Handy Directly.
  • Open a video that has a script with the same file name (except that the script has a .funscript file extension) in the video folder. You need to setup folders in Settings → Paths if you want to have your scripts somewhere else (not tested, but I assume it’s there you configure it).
  • Start the video and your Handy should work fine. You might need to set a script delay in the hidden right panel of the Scriptplayer window to get the Handy perfectly in sync with the video due to network delays.
1 Like

Sorry for the late reply :confused:

I followed your instructions… but… nothing… The video plays, the handy doesn’t move and an empty error message is shown (that one was visible everytime before too, don’t think that i mentioned that). But since its empty, it doesn’t help finding the problem.

Clipboard01

Try the latest beta-version. Release 1.1.1 is quite old by now:

1 Like

Hi!I have same question with my scriptplayer. My scriptplayer is 1.1.1,and my Handy firmware is 3.2.3.
Try this Help → About/Check for new vision → Check Again(inculde Pre-Releases).
Now the Handy can work. Maybe it can help you!