Watch SexLikeReal videos connected to sex toys with your iPhone and Android

We are happy to announce update to Haptics Connect app and with it, the ability to stream scripted SLR content on your smartphone while your sex toy syncs to the video.

All users with active Premium Bundle subscription can start using it right away.

To enjoy it, take the following steps:

  • Install Haptics Connect
  • Pair your device
  • Open Browser on your phone
  • Go to and login
  • Find a scripted video you would like to watch and tap on “Video + Haptics” button

It will launch Haptics connect with same video, all what is left is to press play and enjoy!

More info on our dedicated page.

This is a first iteration, so please take it for a spin, we welcome the feedback.

What else?

We are starting to upload more flat content on SLR, meaning - more possibilities to upload scripts.

Do you have flat videos scripts you are willing to upload to SLR? Send me a DM, I am happy to help and answer any questions you have!


As soon as this update came I can no longer use my quest2 with the app… it only works if I watch it on my phone now.

Let me check with the team what might be the issue and I will get back to you asap

Shouldn’t be like that. Contact slr support or provide site details

Looks like the new update broke the connection to your account, so if you see “Player” tab missing at the bottom, please repeat the step to reconnect it by:

  • open browser on your mobile phone
  • go to and login
  • open your profile and click on “Connect SLR to HC app”

Also you can check this thread that doublevr posted for more information on the app, the team if constantly replying there

1 Like

Much appreciated this is actually what happened. I just had to Link my account to the app again. Appreciate the quick support!

1 Like

I actually opened a ticket with SLR, but I’m having to basically do their troubleshooting over and over each time, then my launch will connect and work like normal but then just stops at about 10 mins running. I’ll keep this updated if they give me any news. Not sure if I’m a outlier or not.

Might there be a problem with your Launch?
I don’t think we get any other similar reports.

It’s highly recommended to upgrade to any newer one. Curios what stops you from upgrading

It would be very coincidental if the issue was with the Launch and not coinciding with the 2.0 (and then 2.0.1) HC. Also worth mentioning has no problems in manual mode.

Upgrading? Not after these two last months of car repairs… :wink:

Launch devices really do seem to die off quite suddenly and without warning - my last working launch was able to maintain a bluetooth connection but could not play scripts on any players I tried, yet manual mode worked no problem, go figure lol

Hey guys - just following up as promised. Troubleshooting from SLR support didn’t prove anything fruitful, so sat down and went one by one on devices and testing to see if the launch would work and found it was something in the wifi and bluetooth.

Checked the router and turned out there was a firmware update which enabled “Bluetooth coexistence” - that has to be disabled (not enabled or “preemptive”) - immediately everything was back to normal.

Hopefully this can save anyone else from an annoying hassle. :wink:


Thanks for following up @frozenorbit ! Great to hear you found what was the issue on your end - I’ve added your troubleshooting tip to our main guide as I’m sure it may help anyone having the same issue going forward, thanks again!

1 Like