Agent mirai v3, Real Life Machine Multi-Device EDI [Update 12/2023]

I took the mod made by vylon and PMVislife , and modified the funscripts to split into multiple channels for diferents parts of the game machine.
so the game machine could be made in real life with a couple of handys and vibratos.

Update (12/2023) in EDI
I finally got the devices to test and found several errors in the code to solve, including those that caused the application to close and others that lost quality when playing or the channels were mixed.
After doing several tests, I think that this version does reach the level in both stability and quality. also added a second vibration channel for the breasts

Variants
just add several devices and depending on where you place it, you choose the corresponding variant in Edi

  • Breast-Vibro-Ch1: Nipples/Breast vibrators or Stim devices
  • Breast-Vibro-Ch2: for your other Nipple
  • Vibro-Anal: Buttplug
  • Linear-Anal: Handys Dildo
  • Linear-Vaginal: Handy Sleeve/Dildo

Mirai, is the original variant that reacts to everything that happens in the game. The other variants only react when the corresponding body part is stimulated in the game.



Download
Game in 4K(6GB)
Game Normal Version(1.5GB)

Multi Device Gallery Patch (Replace EdiDemo Folder)
Reference Video

22 Likes

Has anyone tried it in multi device mode? I couldn’t test it even myself beyond the fact that technically I know it works.

Can confirm it does work. Connected Handy through EDI and the Hush through Intiface and I got it working. EDI still crashes when you hit the buttons like reload galleries or reconnect, but apart from that it works great.

2 Likes

캡처
Fortunately , I have a lot of devices

tcode is dglab(e-stim)
dante is vibrators

handy+ufosa:wellmoved
handy+dante:wellmoved
handy+ufosa+dante:edi stops every 3-4 minutes

dglab is the problem.

dglab only:wellmoved
handy+dglab:moving, but edi freezes sometimes
handy+dglab+other device:hard works. edi turns off

My bluetooth headphones might be the problem.
But I usually use 2 devices.
Setting up more than 3 devices is honestly a pain.
It seems to be enough as it is.

Thanks for a good program.

I tried tcode here, it works great.

1 Like

Now that I remember, my Bluetooth dongle is 4.0

1 Like

thanks for the tests. This week my coyote dglab should arrive and I would do the tests. I understand that many of these devices rely on Bluetooth and I should improve how I manage multiple Bluetooths.

I have to better coordinate all the devices that use blueetooh to manage well how I send messages to X3 devices at the same timeltiple Bluetooth

1 Like

How do you get the uncensored version?

Recently found this mod and it looks great! I’m having similar problems here — EDI will just stop as soon as the game scene starts.

[1] I believe EDI is sending incorrect JSON formats to Intiface Central. Here is what I read form Intiface log:

Look at the part where two commands connect (with a red underline). Such a back-to-back arrays [{...}][{...}] is not allowed in JSON. If you type it into a text editor with JSON syntax check (e.g., VSCode), there will be an error:

A valid JSON may look like [{...},{...}], but I’m not if Intiface expects to see it:

I think this could also explain @vylon’s issues: whenever there are more than 2 devices connected to Intiface, there is an issue. The Handy is directly driven by EDI so Handy + 1 other device works well.

[2] In addition, in Windows Event Viewer, I can read the error log of the crash of EDI:

Application: Edi.exe
CoreCLR Version: 6.0.1623.17311
.NET Version: 6.0.16
Description: The process was terminated due to an unhandled exception.
Exception Info: System.InvalidOperationException: Collection was modified; enumeration operation may not execute.
   at System.Collections.Generic.List`1.Enumerator.MoveNextRare()
   at Edi.Core.Funscript.CmdLinearExtend.AddAbsoluteTime(List`1 cmds)
   at Edi.Core.Device.Buttplug.ButtplugDevice.PlayGallery(String name, Int64 seek)
   at Edi.Core.DeviceManager.<>c__DisplayClass34_0.<<PlayGallery>b__0>d.MoveNext()
--- End of stack trace from previous location ---
   at System.Threading.Tasks.Task.<>c.<ThrowAsync>b__128_1(Object state)
   at System.Threading.QueueUserWorkItemCallback.<>c.<.cctor>b__6_0(QueueUserWorkItemCallback quwi)
   at System.Threading.ExecutionContext.RunForThreadPoolUnsafe[TState](ExecutionContext executionContext, Action`1 callback, TState& state)
   at System.Threading.QueueUserWorkItemCallback.Execute()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading.PortableThreadPool.WorkerThread.WorkerThreadStart()
   at System.Threading.Thread.StartCallback()

I’m not sure if [2] is causing or caused by [1]. It seems points to some looping behavior in the code.

Thanks for making this great mod! I hope this information helps.

P.S.: I’m testing it with an OSR2, a UFO SA, and a OhMiBud buttplug. I also have a Keon and I’m happy to help test things.

1 Like

thanks i going to check this!

@qdot this might interest you

this is strange since I’m using the butplug the c# client. so I don’t put together the json manually to send them over the connection. I just updated the client from version 3.0.0 to 3.0.1.
Maybe that will solve the problem.

As for the multiple devices, it turns out that it had a bug where the delay was 20 mm, which saturated the Bluetooth connection, apart from the fact that it sent 2 individual messages when a device has 2 channels… in the next version it will be possible to configure it the delay from the configuration file, and combines the 2 channels of a device in a single message.

I think the error is something that I already solved, regarding a multi-thread lock

thanks for the detailed feedback

Oh. Huh. The v3 C# client can apparently send multiple commands in a single packet. Oops.

This is something the rust side has a problem with. C# is jsut doing what it’s supposed to.

This is a bug I’ve been meaning to take care of for… 2 years now. I should get on that. :expressionless:

2 Likes

hey, there I updated the mega link for the multidevice patch with the new version of Edi. When you have time, could you tell me if your bugs were solved? I did a work arrown on the buttplug issue. and the errors that closed the application.

@vylon Could you also try it if you have time?

thanks to both of you! for helping me find the errors

1 Like

Thanks for updating the mod! Just tried Day1 in game and it worked well!

1 Like

Thanks a lot for your work! That being said, I find it incredibly difficult to grasp how to install EDI for this game.