Can someone PLEASE explain the timings settings for the handy with scriptplayer?

The most fucking frustrating thing about both is when it is the timings are just out of sync. For instance, I just tried the bukkake script I posted earlier and the timings were all off. So, where there is in the beginning some strokes where you have a snare, then bass, then snare…I don’t know what else to call them.

Screenshot (318)

Well, the snares should hit at 0 and the bass at 4. But it was just the opposite. It pisses me off. And NO MATTER how I adjusted the timings, it did NOTHING. Same result.

Also, do you guys have the timings in the positive the majority of the time or negative? There are periods where my timings are set for -225 and they are all good. Recently, I have had them in the positive around 100. And they have been fine. Is this normal for them to fluctuate? Is it a scriptplayer issue? Handy issue?

This is THE MAJOR drawback with the Handy. When they are in sync, it is hard to beat.

It shouldn’t be caused by TheHandy and their servers if you need to set timings to positive for it to sync. The whole point with a negative value is to compensate for the fact that network traffic takes time so you need to send data a little bit ahead of time to make it sync. If you set a positive value then you basically say that you delay sending data after something has happened to make it sync. Therefore the setting should always be negative. Theoretically it could be 0 but then you must live very very close to the servers. The only reason for having a positive value as I can see it is if the time stamps from the video playback are wrong somehow.

The network delay can fluctuate if you have a really bad network connection or the servers are under heavy load causing response time to fluctuate, but usually the delay should be stable. I have a fiber connection and I use either -25 or -50 to compensate for network delays. You usually have higher delays in 4G/5G Internet connections, but I don’t know if that delay is stable or if it fluctuates a lot.

1 Like

Well, at least this makes more sense. I just plugged in again and it was perfectly synced. Or close. I have fiber as well. It just seems I have had to often tinker with the settings.
Thanks so much for at least some kind of explanation for the timings. Very much appreciated.

When do you notice the sync issues? I’ve noticed that over long sessions, the handy can start to get sluggish as things get too hot. If you look at the videos ov people actually using their handy (, you can sort of notice it

no. it is at the beginning and all throughout. I set it to 0 like @sentinel suggested and it is SO MUCH BETTER. I guess I just had the timings way off. From here on out I am going to leave it at 0 and adjust accordingly toward the negative if it calls for it. It is mostly noticed if it is off with PMVs…mostly those I script because I want precision…not to say others don’t, but I know EXACTLY how I hope them to turn out as I script.
Thanks @dastardlii for your response and advice.

Zero delay is most likely not the delay you should use. You can check your latency by connecting your Handy at the manufacturer site HandyFeeling . Drag a video and a script into the boxes and then you should see the latency in the lower right corner (beneath the slider controls), e.g. Latency: 46.94 ms. This means that you need to set -50 ms delay to compensate for the delays caused by network and server.

The picture is a bit old since I copied most of this from an old post I wrote last year, but it shouldn’t differ too much I hope.

My other advice, if you have the ability, is to just use the handy in bluetooth mode instead of through handyfeeling. Especially when going through scriptplayer, it’s so much better it’s like night and day.

Yeah @dastardlii . I think you offered that advice when there were Handy server issues. If you didn’t and was someone else, I apologize. I did that. I didn’t like it. It missed ALOT of the nuance and strokes I scripted. Maybe I just thought it wasn’t HITTING like I thought it should.
@sentinel I will check the latency. I didn’t know about that. That helps ALOT.

Thanks guys SO MUCH. I really do appreciate it. :pray:t3:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.