Connecting Oculus Go with Launch

Is there any way to connect Oculus Go with launch? I have tried the SLR app on Go but there seems to be no way to connect to launch with Go’s bluetooth

2 Likes

Hi Nether,

I use the Go and a Launch and it took me a while to work it all out. You will need to download SLR onto a smartphone to act as a bridge. Few things you need to do.

Put all of your scripts into the folder on your GO called Interactive. They need to have the same name as the movie so movie.mp4 would be movie.funscript

The films can either be on your Go or even better on a DLNA server. (I use Universal media server.)

Log into either the SLR app on the Oculus Go or use Deo Vr player and go to the sex like real site.

Once at the site log in on both the app on your phone and the site. (make sure its the same log in for both.)

Click the settings button on the top right and make sure connect to SLR is toggled on.

Turn on your Launch,

On the app on your phone click find bluetooth device it should detect the launch and you will hear the welcome strokes.

Click a video and it should then work. If you have done everything right the playback bar will have a little blue icon of a fleshlight.

If your still having problems let me know.

3 Likes

Step by Step Tutorial - to connect your Launch with a Headset

2 Likes

Or - if you don’t mind using a PC as middleware - try DeoVR and connect it to ScriptPlayer
(Downloading Beta Builds · FredTungsten/ScriptPlayer Wiki · GitHub)

2 Likes

It says DeoVR not connected. What do I put in the IP options to connect it to DeoVR. The other option is working, thank you all.

2 Likes

You just need to enable remote control in DeoVR (settings), enter the IP/Port in the settings (e.g. 192.160.0.100:23554) and select “DeoVR”.

2 Likes

Not sure what is causing this … I did enable the remote control in deovr

1 Like

Huh weird.
Maybe wrong IP adress or your WiFi is DMZ’d?
Can you ping your phone / connect to other apps on it?

1 Like

Thanks so much for these tips, much easier than my previous solution with Whirlgig and SteamVR.

However, I currently have the problem when I’m streaming videos from my Mediaserver to DeoVR, the file name is not correctly delivered to ScriptPlayer so it doesn’t load the script file. Instead of the real file name it shows something like “50.mp4”. Any ideas?

1 Like

Hi Quiffed1,

Sorry for high-jacking this thread. I spun up the Universal media server and tried viewing the videos on Oculus Go. DeoVR is unable to recognize the funscripts rendered by DLNA server however local funscripts are working fine. Do you know what might be the issue or if I’m missing something here? Appreciate your help with this. Thank you

1 Like

Hi Akgcool46,

No problem I know from experience it can be tricky getting everything working. First thing to know is that the funscripts have to be on the oculusgo not on the DLNA server. The videos should be on the server but the funscripts need to be in the folder called interactive. The other thing is that the funscript needs to have the same name so movie.mp4 is movie.funscript.

Luckily funscripts are such small files that you can basically load all of your funscripts onto the Go and it takes no meaningful memory space.

Hope this helps if its not i want to check a few things
Are you able to view the videos from the DLNA
When you view them do you see the blue icon on the player bar.
Finally test it with the funscript and video in the file below.

They are already named correctly so as long as the funscript is on the headset and the video in your DLNA it should work.

Let me know how you get on.

3 Likes

Hi Quiffed1,

You are awesome. Thanks a lot! Got it to work after having the folder “Interactive” in Oculus and moving over the scripts to that folder.

1 Like

How did you guys get Universal Media Server to work with Oculus Go/DeoVR? It doesn’t recognize my device and either shows a spinning circle or media format not supported. I tried fiddling around with a custom rendering profile but got nowhere…

1 Like

Hi Idefix337.

I occasionally get the error your describing usually rebooting the Go fixes it. If you get the media format not supported that can indicate a problem with the video itself. It may not have downloaded fully. Try opening the video on your pc and skipping forward to near the end to check if the video is corrupted.

The other thing I can suggest is make sure your only sharing the folders that need sharing and create subfolders to minimise how much it loads when you select a folder. Also sorting everything into folders tickles that OCD part of the brain quite nicely.

Hope this helps.

1 Like

I’ve never had any luck getting DLNA working in DeoVR on the Go. I think they were working on SMB support, hopefully that’s easier.

1 Like

@stustustustu - try these latest updated tips for getting DLNA working in DeoVR on the Go - It should really work for you (tips are near the bottom of the thread)

https://forum.sexlikereal.com/d/805-interactive-sex-toy-scripts-complete-help-guide-launch-onyx-the-handy

1 Like

@Realcumber - Thanks, will check that out tonight. Other issue I have is DeoVR doesn’t even find the DLNA server I use with Pigasus (XBVR).

1 Like

@Realcumber - Just had a look. Getting script files to work isn’t actually the problem (it actually works surprisingly well), it’s getting DeoVR to work with a DLNA server. Sometimes it works, other times I get ‘Internal Server Error 500’.

1 Like

Thats good news!

DLNA should work consistently, but there may be small things u need to try or make sure of:

Have you tried all the steps I compiled from my help guide here?:

Local folder Script Support (DLNA works as well!):
-Simply put a [videoname].funscript into “Interactive” folder in root on Android devices and /Documents on Windows. Once there you can play videos from anywhere to catch up with the script.
-Enjoy it over DLNA as well. SMB support is in development and might arrive soon.
-Enable “SLR Interactive” toggle in Global settings.

Local folder Script Support on OCULUS GO (DLNA works as well!):

  • Clarification on the Oculus Go issue with watching videos via DLNA Network AND wanting to play scripts with that:

1.It is POSSIBLE. Setting: Videoclips all on my NAS Server with activated DLNA Client
2. App for watching VR/Normal Videos on Oculus Go: DeoVR (normal Version, download for free from Oculus Store, no sideload required)
3. SLR Interactive App running in same WLAN on different Device (in my case my android Smartphone, here BLuetooth and Location have to be activated for Parining with Launch or wathever Device
4. ALL Scriptfiles (no matter, if the video files ar on the GO itself or in the Network) have to be stored on the Oculus Go in the Directory shown on the Picture below. Works great ! Have fun

Q: PLEX HELP:
To get Plex to not mess with the names over DLNA, instead of movies, make a library under Other videos (or something along these lines.

Problem then is, when you browse the files over DLNA is puts the year at the end of the name of when the file was originally created.
abc - def_xyz (2018)

If you then go to plex to remove the date (which is the full date yyyy-mm-dd) you can’t select all the videos and remove the date because they are all different.
But what you CAN do is, instead of removing the date, give them all the same date, ie 2020-1-1

Then Plex gives them all that date, and then you can again select all the videos again and remove the date of all of them at once

1 Like

Thanks, did some more playing around and I think everything is happy now.

Now for the next step, replace my Launch with a Handy.

2 Likes