Deleted 10 characters 37

deleted 10 characters 37

Have you tried typing diskmgmt in the search bar to see if its there?


Try using a Ubuntu Live System to access the data. You need to flash it to a USB drive and boot it from there.

If it’s an corrupt NTFS partition there are tools to fix them: partitioning - Fix corrupt NTFS partition without Windows - Ask Ubuntu

Edit - Better tutorial:


You can try to use diskpart.

Open “CMD” and type “diskpart”
Then enter “list volume”, look for an NTFS Volume with your 20TB.
If it’s there, enter “select volume X” X is for the number of the volume.
then type “assign letter=XY”.

Else, you can try to unplug the disk and plug it back in.

It’s the only way I can think of right now. I had similar Problems but couldnt solve it. My HDD was dead.

1 Like

A cautionary tale and reminder to back up your stuff! Yeah it’s a pain but the alternative is worse.

Check Disk Management (Create and format hard disk partitions) in windows and see what’s going on there. If it doesn’t show there, I echo the other poster try cmd, then diskpart


Sadly it’s NOT showing up in diskmgmt. The HDD only shows up in BIOS.

I cant type ANYTHING in diskpart after typing “diskpart”.

I only get the Standart Windows Diskpart Message

Microsoft DiskPart-Version 10.0.19041.964

Copyright (C) Microsoft Corporation.

I cant type NOTHING after that.

Try to run diskpart with administrator privileges.
For me it’s asking to allow it when i typed diskpart, after i confirmed it.

@Leelerer I already tried that multiple times with no luck :cry:

Have you tried plugging it into a different computer?

@Bounce I sadly have no other computer :cry:. It’s a dilemma…

Perhaps you can try using a different usb/sata port/cable?

Strongly suggest trying the Ubuntu route @Wolf7 . Had this happen to me once and was able to pull off files going that route. I had to format still but was able to get main stuff I cared about off.

Also check off Backblaze for your backup needs they have a very reasonable plan for unlimited backup. Just stated to back up my stuff the other day.


Thank you everyone for the answers!

I tried everything till now. I will throw it away :sob: fuck.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.