[Dieselmine] Mira and the Mysteries of Alchemy (Game Integration) - EDI

:framed_picture: Preview

Animation Samples

1b45ee05c2a95aee677c5c8a8e58b5c2 cd2be0d9c442793b00dba0c40f8791d28 784a94375a130874c99c2f4667e77f2c

:information_source: About Game

Mira, the alchemist in training, fails at making a potion and becomes a futanari!
Work on creating a potion to fix her futanari penis while dealing with different
witches and monster girls that come looking to drain her!

:scroll: Mod Info

This mod utilizes EDI, which was integrated as a RPG Maker plugin.
The game difficulty was also adjusted so that the player has more HP and the animations last longer, as well as recharge faster.

:memo: Notes

  • The Animation, as well as all the CG-Scenes are included. Big thanks for the awesome scripts from everyone involded!

  • Filler and reaction scripts are included and can be turned off in EDI (especially if you encounter issues with the reaction scripts during escape).

  • If you encounter any issues or have suggestions, please provide feedback.

  • Tested with the Handy on the KaguraGames [English] version v1.01.

:computer: How to Use

  • Step 0. Get the game.
    If you have the Steam version or need to apply the uncensored patch (recommneded),
    do so now as well. - DLsite Kagura-Games Steam

  • Step 1. Download and extract the right Mod version into the game’s main directory.
    Replace any existing files.

  • Step 2. Launch “Edi.exe” and use your Handy key to connect over WiFi.
    You can also use the Intiface Bluetooth connection for the Handy and other devices as well.
    It is also possible to enable/disable the filler and reaction scripts here.

  • Step 3. Start the game and have some fun with Alchemy. Flask

:link: Download Links

:card_file_box: Integration Mod:

:film_strip: If you’d like to create different script versions, here’s all the reference content:

:game_die: Game:

:medal_sports: Credits

A big thanks goes to:

dimnogro for the EDI program:

99DM for all the Animation-scripts:

Morrigan and Zerostress, who worked together on scripting all the CG-Scenes!
(Morrigan: CG Script 11-21 / Zerostress: CG Script 1-10)


  • 22.11.2023 - v1.3 Version Support
    • Added mod variant that supports the DL-Site version
      • Added japanese language support (only tested with DL-Site)
    • Minor bug-fixes

  • 22.11.2023 - v1.2 Hotfix
    • Fixed an issue with script-playback that would occur when using the gallery under certain conditions

  • 20.11.2023 - v1.1 Version Support
    • Added support for the Steam version

  • 20.11.2023 - v1.0 Initial release

Legend, thank you so much!!!

1 Like

Keep getting an error after copying files over from the mod. (Steam Version with Uncensored Patch). If I revert the files that go into the www Folder, works again but of course doesn’t properly connect to EDI for gallery/CG.

Occurs when starting new game or loading.

1 Like

Same error here. Excited to try this integration out!

1 Like



Was a pleasure working with you :smiley:

1 Like

There might be a different structure for the Steam Version. I’ll have to get that one and adjust the mod accordingly.

1 Like

I updated the mod so that it can work with the Steam version as well.
Let me know if you encounter any issues.

1 Like

Could an error occur depending on the game version?

It’s possible. I only tested the mod with the English KaguraGames edition and briefly on Steam, both with the latest 1.01 version. So I don’t know what how the game was built in other variants.
Which version are you using and what error are you encountering?

1 Like

works great!, love it!

1 Like

When checking the details folder, it seems like the filler funscripts are missing. The filler is not working for me :smiling_face_with_tear:

The fillers are all contained in the “Extra” funscript.
As long as you have them enabled in the EDI-Player, they should start playing after you’ve had the first enemy encounter.

1 Like

I purchased it from Kagura Games and when I click New Game after applying the mod, an invalid regular expression error appears.

Can you provide the exact error message?
You could also try again with a clean version of the game and apply the uncensor patch first, then the mod, and see if that helps.

Thank you, it’s resolved now

1 Like

Works a treat!

1 Like

Thx so much.
can i get old ver 1.00 mod file?

there is only 1.01 mod file.

1 Like

Yeah ! Finally released !

1 Like

Have you tried it with ver 1.00? The Mod might still work with it.
Otherwise, if someone can provide ver1.00, I could look into it.