Error with a test script I created

I created the attached script, but when playing it on the handy, it doesn’t actually do half the actions. The intended behavior is a slow stroke 100-30, fast stroke 30-0, then fast stroke 0-100, but the result is a short downstroke, long pause, short upstroke. I’m guessing that it’s not possible to have two consecutive strokes in the same direction? If that’s the case is there a known way to emulate a non-constant speed stroke?

test.funscript (3.3 KB)

dont have a handy but if your right and it cant do 2 strokes in the same direction then you could try 100-30 slow then a very fast 30-40 > 40-0 >0-100.

on the other hand your stroke may be TOO fast so before it can do the 30-0 its already looked ahead and read the 0-100, stretch out that 30-0 a bit longer and see if it wont go down, if it just twitches down then back up you will need to make it even slower for it to actually do the command before trying the up stroke.

You can absolutely have multiple actions in the same direction to create any shape you like…

When you say “short downstroke, long pause, short upstroke”, do you mean that the downstroke and upstrokes are too short in position (i.e. it’s only moving 0-30 rather than 0-100) or do you mean that they’re short in time (i.e. fast)?

How did you create the script?

Created it with OpenFunScripter. I’ll try and post a video later, have been running it on the Handy using both and handycontrol (versions 1.0.0 and 1.0.1).

The result is a lot of completely inactive time in the actual playback, as well as never hitting the full range, vs what should be constant movement. The actual time spent moving is at best 50%.

Try pressing the up button on The Handy 3-4 times and see if the stroke length increases.
Secondly, try adding ,“range”:100 before the last } in the script file and see if that helps with the range.

The script runs normal on my machine.

You have to keep in mind that slow slopes can result in Handy getting stuck in its movement. Thats why the minimum automatic speed is 32 mm/s and not 0 mm/s. Scripts can go slower than 32mm/s so you can see this issue sometimes. Your down stroke is slow but it still works. At least on my side.

HandyControl does not use this setting. It remembers your last stroke range in the app.

1 Like

If you set points causing it to go slower, can that cause the script to stop and not resume until you skip forward or backword and thus “resync” the script?

Video of script in action (or lack thereof):

It will catch up after a few missed strokes by itself.

Where is this slider?

How do other scripts play?

Set to 100.

During playback the following behavior happens:
Long slow downstroke: speed slider sets itself to 100%, no motion on device
Short fast downstroke: speed set to 11%, a short downstroke on device
Short fast upstroke: speed set to 33%, a short upstroke on device

The handy isn’t doing anything during the long downstroke in the script, and definitely not making it to the 100 position at the end of the upstroke (as illustrated in the video link above).

Other scripts seem to play fine? I’m rarely looking at the line graph while they’re playing so if they’ve dropped an action I’d probably just assume it wasn’t scripted to contain it.

The question is, if other scripts do use the full stroke range. Are you on firmware 2.13?
What happens if you press the up button on Handy a few times?

Open connection settings and press the Get Version, Get Status and Get Settings button.


My Handy also does this sometimes, try this.

Before you plug in the handy manually push the slider to almost the top, about an inch from the top. When I say manually I mean use your fingers to push the slider up.

Then plug it in and let it calibrate.

Before you connect the handy to wifi, put the handy in manual mode (light should be green)

Push the up button until the handy is at full stroke, then hit the stop button and stop the slider when it is twords the top of the stroke.

Now connect to WiFi and load up your script and see if it is playing in sync correctly.

That shit doesn’t work boss, tried it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.