Fleshlight Launch incorrect ranges?

Has anybody ever gotten this issue with the Fleshlight Launch, the discontinued one? It has only started happening recently I was just wondering if there was a fix to this, when I turn it on recently, and switch to manual mode, when I activate it, it makes its usual movements but the machine moves it way too low and it hits the bottom of the case hard(with nothing attached to it yet), as if it’s ranges were set incorrectly which causes it to jam and the light begins flashing red. I tried in Bluetooth mode with a custom script to limit it’s movements, sometimes fixes it with custom scripts, but I have to severely limit its range of movement, for example, minimum ranger 25% and maximum range to like 60% otherwise it hits the top or bottom and becomes jammed with the red blinking. Another odd thing is that this range can change from day to day, like one day you have to limit it to 20% so that it avoids hitting the bottom of the case and jamming, another it may be 40, I have tried several times opening it up to see how I can fix it, readjusting the screw up higher to avoid hitting the bottom which sometimes fixes it temporarily for a day or two, I also tried to update it but the system seems to have been up to date as the cellphone app did not prompt for any updates for it. Recently it has become unusable because even if I open it up, and try to readjust it, it eventually jams again,

1 Like

There is supposed to be a small magnet on the outside of the receiver (facing the main PCB). If this magnet is loose or missing, the launch won’t be able to home properly. If you move the slide to its top position then power on the launch, it should move the slide down and stop a small distance before reaching the bottom.

If the encoder is busted or not making good contact you would expect the homing procedure to work correctly but the device to become unreliable and move erratically once it is running.


Brilliant! Thankyou so much, I swear I have done just that before and it somehow repeats the problem again, but just did as you suggested, moved the moving frame upwards to the top, then turned it on, and now it works normally. For making this dummy proof for me, by magnet do you mean the flat thingie thats really close to the brown spinning wheel above the motor? Seems slightly magnetic to me, although the magnetism seems very very weak. I absolutely neglected to mention that my Launch fell once, although showed no signs of issues for months, may be related, but I feel happy that worst case scenario by what I’m hearing, it’s very fixable.

Update: Now that I think about it carefully, the case was not closed neatly, and the plastic rattled alot, I think somehow the vibrations may have messed with the magnet and encoder slightly and had it confused, I did as you said, and this time I made sure that the case was perfectly closed, and now it won’t jam at all no matter how much I try and recreate the problem! I never thought slight vibrations up there would cause it to go haywire like that, assuming that’s what was messing it up. Thanks, I think you saved the day!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.