Handy has a mind of its own!

Hey so I noticed my handy seems to have a mind of its own and apparently its a complete fucking jackass.
Ill run a playlist and after a while it does whatever it wants sometimes just stopping when theres clearly actions in the script, sometimes I pause and it will stop and then just keep going after a few seconds and not even doing the actions in the script! Its not overheated, and the scripts I play rarely go into orange let alone red so its not an issue of keeping up. Needless to say its ruined a few sessions and Im getting pretty fucking annoyed. For the price I would have hoped to have something last more than a year, not like that piece of shit launch.

Edit: Ive only used the handy closed sleeve or a quickshot, no heavy fleshlights or anything like that

Which firmware? Check Update - HandyFeeling you should be on 3.2.3

It is, i connect and check for updates everytime i use it. No dice on that front unfortunately. Although deovr tells me to update when it is updated. It also wont play some videos i dled from slr anymore (played fine before) so i stopped using that.

What player are you using now?
Do you use ScriptPlayer? Is it updated to last beta?
I had similar issues with Pigasus (on the Quest 2) before.

It doesn’t necessary have to be the Handy. As usual you should try first:

  1. Check with app other than DeoVR to confirm it’s not related to software.
  2. Try to downgrade Handy back to FW2 and upgrade it manually back to the newest release. I think there used to be some bug when sometimes it showed you are on a newest version, but apparently you are not for some reason.

I used whirligig until it stopped connecting to scriptplayer and then eventually couldnt play the same slr videos so i switched to skybox, doesnt play scripts but at least i can watch the damn video.

I tried that before its no bueno, other videoplayers i cant get to connect to scriptplayer whether its the newest update or past versions. Vlc/mpc hc/whirligig will not connect tonscriptplayer. Deo does connect and load scripts it just gives me a black acreen qhen playjng half my vr library

Yeah I don’t know what’s going on there lol. Try latest ScriptPlayer ( ScriptPlayer - AppVeyor) it should work with Whirligig. Otherwise try HereSphere on Steam, there is a also a demo available (has a nag screen) and it has Handy API integrated so you don’t need ScriptPlayer.

You may have other issues if nothing connects to your ScriptPlayer. Maybe you messed up your OS, messed up settings, stupid AV software in the way, horrible codec packs if you have many files that can’t be played (DeoVR is shit anyways.) , it could be a lot.

Also see that you have HEVC codec installed.
You can find them for free on : Codecs.com | Downloads for HEVC Video Extension 2.0.51121 (free-codecs.com) choose the x64 one.

But yeah, I’ve used Heresphere for a while now and don’t need other player rn.

I’ve had my Handy last week just drop Wifi every couple of seconds. It connected to the Wifi and Scriptplayer like always but then dropped wifi after a few seconds and the purple light started blinking. It seems to work fine now again but yeah since then I have the feeling that the Handy has a mind of its own, too :sweat_smile:

1 Like

To find issues you should try (if you haven’t already) to run your Handy minimalistic to eliminate sources for errors. Try running your Handy with a few small videos and scripts directly on the Handyfeeling web site and see if that works. They might even have some free working sources on their website (I haven’t looked).

If you can’t get it to work then you should first check that all services are up and running:
If all are green then try using a support option that the TheHandy team provides on their support site:

There you can find:

  • email contact
  • a chat bot with a chat with a human option

Other support alternatives are:

  • TheHandy Discord channel The Handy (Official) (server invite link may have an expiration date)
  • TheHandy on Reddit. Unfortunately reddit requires login nowadays to “prove” you are 18+. I don’t have an account so I don’t know how their channel look like today. They used to provide support that way before when it was open to read without a reddit account.
1 Like

Honestly mine has issues sometimes, itl flash purple then flash red then go green and ill retry a few times and it finally connects. Kind of wish i could just plug in usb or something at the end of the day whats another wire? Things not portable it needs a power outlet.
Biggest issue i have is internet connectivity, does actually being online matter? Or does the script get sent from computer to router to handy? Cause my wireless router is baller and my stuff sees it from pretty far but actual internet is iffy sometimes, i am very rural so i use satellite for internet. Although it worked fine the first few months i had it. Ima give @sentinel advice a shot once im back home, should be a day or 2 depending on weather/health/luck :slight_smile:

That could be a bad internet connection or the fact that the servers are under heavy load.

Yes internet connectivity matters and yes the entire script get sent to TheHandy in the beginning, but TheHandy need time stamps to keep the script in sync with the video. I don’t know how often it need to resync though. The ideal case would be when you press play or skip forward/backward in the video, but I wouldn’t be surprised if TheHandy resync at regular intervals to make sure that it doesn’t drift. I haven’t looked at the API:s myself but there are probably others here who know the specifics since they have integrated software with TheHandy.

Personally I see that as a plus. I can’t remember how many times my Launch ran out of juice mid session and from what I’ve heard the Kiiro won’t charge unless you have drained the battery low enough, i.e. you can’t be sure that you are able to charge it to full when you intend to charge the battery. However, this about the Kiiro is second hand information so my apologies if I’ve got it wrong.

I would highly recommend Heresphere as well. You can get a free version from their website and play scripts and videos all in one. On a side note, depending on how long ago you got your Handy… there is also a fix for the loose cable. The Handy is now updated on their website to include an elbow plug which gives a tight fit and doesn’t fall out. You can go to their website to see what this plug looks like, then just go to Amazon and order " 5.5mm x 2.5mm DC Power Extension Cable 90 Degree Right Angle Male to Female Plug Jack".

Actually it can be a lot of stuff reading through your comments but it does not seem to be a handy issue per say.
It could be bad network, if you live in a place where there are lot of WiFi networks it can affect yours latency or even cause the handy to not connect / lose connection.
It can be the handy server.
It can be standard network latency if you live in a place that is far from handy servers.

I switched to bluetooth with my handy when FW 3.0 enabled it.
(A dongle is like $10 if your PC does not have one… you are playing with a $200+ toy already.)

Best decision ever, no network lag, ISP outage or handy server outages.

How to set up:
If you use ScriptPlayer already, just switch to bluetooth mode on the handy (long press wifi button, led will be blue). If not, download it (I do not have a link ready search for it :smiley: )
Install Intiface, run it, left side you will see the Server Status
menu, click on it and click to start server.


Now in the ScriptPlayer you can Connect to Intiface instead of the handy directly and hit Scan for devices. That’s all, you should be good to go.


If you did everything right you will see these to pop up.

Also under Devices / Show devices you will see the handy

You can even set up, so you do not have to do a singe thing once you started ScriptPlayer.
So next time you want to play, put handy in BT mode, run ScriptPlayer and just start you videos.

Here are the script player setup (Show device manager is optional):

And here is the intiface setup:

Also it seems the script player will direct the handy based on the script, so you do not have to upload them to the handy.
(No this is to big of a script or it is the x th in this session and we couldn’t handle it properly issues.)

And I also noticed, let say the handy should go from 0 to 100 in 0.1s and back to 0 in the next 0.1s and handy can not do this, with script player and bluetooth it will still try it, it will go to 50-80 or whatever is possible and after the 0.1 sec the script player will give the new direction and it goes back to zero.
As I said I do not use wifi from a while so I do not know what would handy do nowadays, but in the past it usually just jittered when something like this happened.

1 Like

I wouldn’t recommend Bluetooth for the Handy as I’ve heard that scripts don’t feel the way they’re supposed to, even if you change the command delay in ScriptPlayer to a lower amount. So if you have other choices, don’t use it.

By Odins beard theres a lot of replies and info! Thanks everyone! To update (im still not home, but should be by evening hopefully) I have 0 issues with wifi and signals my closest neighbour is about 10km away so unless bears and raccoons and shit are using cell phones (id believe it wirh raccoons, theyre way too smart) shouldnt be an issue.
Im happy that handy uses corded power im just saying an extra cord (usb direct connect) wouldnt be an issue for me if it helped.
My computer has bluetooth, and yes a dongle is 10 bucks BUT i have to drive 1.5 hours to get one amazon doesnt deliver to me hehe. Im not joking about being very rural, i am literally in the bush i grow/hunt/fish my food and theres no infrastructure, my power comes from solar/wind/hydro and my poop becomes fertilizer for next years food.
Anywho I will try and go through all these things tomorrow and see what happens and will post what worked and what didnt for future reference and maybe add it to the “how to” section! Again thanks everyone!

1 Like

So, heresphere looks great, seems great, doesnt work on on a TON of videos, seems like it cant handle anything past 4k resolution? Anyways once again half my vr library will not play, skybox plays it though! Anyone up for getting scriptplayer and skybox to connect?
I dont know if I forgot to mention but this is all on a new computer, my last one died horribly. New computers way faster, 12th gen i7 and rtx 3060ti. Videos play on windows media player, vlc and skybox perfectly just not on any player that can connect to handy or to scriptplayer. I dont know if i need to download codecs or LAV filters or what but i assumed that these vr players can in fact play vr videos, especially seeing as they are all mp4 files, which seems to be the most common type across the board whether its 2d or 3d or vr or movies or porn or anything.
Also, could not connect to intifiace, i tried and everytime it went through 10 attempts and gave up.
I have no idea why everything has failed in the last couple weeks when it all worked fine before then.
The god of wanking, Testacles, must me angry with me or something.

It has to be codecs, try installing these: Releases - Nevcairiel / LAVFilters

1 Like

I use Script Player and my Handy doesn’t play the scripts properly if the script’s name has certain symbols in it. Exclamation points, periods, parenthesis’, etc. I fix the name and everything runs fine.

I do have some issues with ‘machine timeouts’ on 30+ minutes sessions, but this happens with both the script player and remote control. It’s annoying but not frustrating enough to ruin the session.