Has anyone else noticed the Handy losing accuracy and precision with very slow movements?

Ever since I got my Handy I have been very impressed with how accurately it can follow extremely fast changes in a script.

I’ve begun to notice something very strange though, which is that at slow speeds, it seems the less distance the Handy has to move between direction changes, the less accurate the timing of those changes are, which makes literally no sense to me. I discovered it when I wrote this slow script with very short stroke lengths like this:

Every time the script reaches this point, the Handy consistently gets ahead of itself, making the script seem out-of-sync or inverted. To ensure that it really was the short stroke length causing this, I edited that exact script so that the bottom points were at position 0, without changing any of the points’ horizontal positions, like so:

And my Handy syncs up with it perfectly. Changing it back brings back the problem, and compromising and moving the bottom points from 7 to 5 makes it almost in sync.

Another even stranger example is what happens when I attempt to play this script:

During that slow descent on the right half of the script, my Handy slowly moves upward in the opposite direction for some baffling reason, and it completely skips the sharp movement upward on the far right before continuing back downward and syncing up with the script again. BUT, simply moving the bottom point on the left from 5 to 0 like so:

for SOME REASON allows the part on the right to play properly. I’m so confused. :confounded:

Is this normal behavior for the Handy? Is there some sort of technical limitation I’m unaware of that could explain this? Have I just never tried to script anything this slow before which is why I haven’t noticed, or maybe this isn’t normal and my Handy is malfunctioning?

I REALLY wish someone else would test the script with their Handy, as it would help me to know for sure if there was something wrong with mine, so if you’re not upset by furry porn and are willing to give it a shot yourself, use THIS script (not the one in the actual Perdita’s Passion post since I edited the problematic parts in that one):
Perdita’s Passion Parts 1 & 2 [For testing].funscript (13.4 KB)

with this video from 2:30-2:45: 116.47 MB file on MEGA

Any and all advice and insight into this issue is greatly appreciated.

The handy has a minimum speed it has to hit otherwise it gets off sync, I know the maximum speed is like 600 ms but I’m not exactly sure what the minimum speed is….

1 Like

Thanks for replying!

If you’re right then my theory is correct, that it really IS a technical limitation causing this issue and not a malfunction with my device in particular. Can anyone else here confirm this?

If that is the case I guess I’ll just have to write my scripts a little differently. I already found a decent workaround which is to just add a mid point on the curve between the top and bottom points of the slow strokes that cause problems. It’s not as smooth which is kinda disappointing, but it does seem to fix the timing issue.

I’m also just now realizing a good place to get more info on this would be the Handy Reddit or Discord. If I learn any more details I will post them here.

i had this problem and fixed through oiling the metal rod you can see from the back

Really? I lubricated the screw about a month ago because my Handy was getting kind of noisy. It’s still nice and quiet and seems to move perfectly smooth, but maybe there is still just a little too much friction in there. I’ll see what people on the Handy discord say.

1 Like

strange, I have the opposite problem, going slow it’s usually perfect, but going fast it will lose accuracy and precision…

This was very helpful info to have, thank you!

The strokes in the original script that are causing the problem I calculated to be about 40mm/s at the slowest, so a decent margin above the Handy’s minimum speed of 32mm/s according to the post you linked me to.

After that I realized that it may NOT be the speed that’s the problem, but some sort of obstruction or extra friction on the Handy’s screw as @cozyblanket mentioned, so I did an experiment. I kept those exact same strokes, but moved them to happen on the bottom of the handy (from position 0 to position 3 instead of 7 to 10) and they synced up fine! I don’t see or hear anything obstructing my Handy’s movement but I’m really beginning to think that there may be something causing it to stick when it’s in the higher positions. I’ll give it another lube job and report back.

1 Like

Maybe you already know the reason for it, but I mention it in case others don’t.

A long scripted movement during too short time might end up in exceeding the device speed limit. This causes the firmware of the device to reduce the speed to what it can handle and that means that the full stroke length can’t be achieved. As a user you experience this as shorter strokes than what is actually scripted.

Short and fast strokes might also be affected. This is one of the things that differs TheHandy firmware v2 and v3 the most. In v3 the direction changes are more soft, i.e. the device reduce speed slightly earlier before the actual direction change to make the turn more a bit softer. However, this was experienced as that the device didn’t feel as fast as it was with firmware v2. I think you can find some threads about it here or reddit where users debated the v2 vs v3 firmware if you are interested.

Well I tried re-lubricating it and the problem persists… :disappointed: Also as I’ve continued experimenting and testing I’ve noticed that my Handy’s performance on the problematic parts is inconsistent. Most of the time it’s completely off, but about 10% of the time it is much closer for the first half of the 15 second section.

At this point I’m thinking it is probably some combination of my Handy not running quite 100% correctly, and the scripts in question just being pretty close to the Handy’s minimum speed.

I REALLY wish someone else would test the script with their Handy, as it would help me to know for sure if there was something wrong with mine, so again, if you or anyone else are willing to test THIS script (not the one in the actual post since I edited the problematic parts in that one):
Perdita’s Passion Parts 1 & 2 [For testing].funscript (13.4 KB)

with this video from 2:30-2:45: 116.47 MB file on MEGA

That would be awesome.

A little off topic, but what type of lubrication did you use on the Handy?

This stuff: Multi-Purpose Synthetic Grease with Syncolon® (PTFE) - 21030

People in the Handy Discord server said it was good.

EDIT: Didn’t realize you weren’t replying to me, but I’ll still leave my comment up.

Ah, I just hit reply, but thanks so much for the suggestion. I’ve been meaning to try to add some lubrication to mine but just didn’t know which type to use.

So thanks for the info!

Have you tried posting on thehandy discord? You might have a better chance getting a reply from their support there.

Oh, I thought exceeding the devices limit is what causes the light to turn red and the handy to stop… (that and something obstructing the path) …

what causes the device to turn red when nothing’s obstructing the path then?

Red can be many things depending on the alternating color. Look at the following link for color codes and meaning. It is for firmware v3. If you use an older version there is a link in the menu for that too.

As I said to someone else, TheHandy discord is probably a better place to get support since the devs or official support personnel are responding there.