EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

Help with VR OSR2 setup

Howdy,

There is quite a bit written about this, but at different times and with different results so I thought I would request some help.

I just picked up an oculus quest 2 that I am looking to pair with the OSR2 and I am curious what you find to be the best setup.

At the moment, my pc is running through wifi, and I am hoping to avoid a wired ethernet to my router (we keep it in our living room where playing isn’t an option).

Any and all advice is appreciated.

1 Like

Hey bud,

Welcome to the OSR2 family. I also have an oculus quest 2 and my current setup is to connect OSR2 with XTP Player via wired USB.

With XTP, I host all my scripts locally and connect using DeoVR with Oculus Quest 2’s IP address. The easiest way i found to find the IP is to download Sidequest on your computer, connect Oculus Quest 2 to computer, and sidequest should update with the current IP.

You can also use JoyFunPlayer 3.0 which is available via Raser on Tempest’s discord. For that you connect the OSR via your sexlikereal username & password, which is honestly alot simpler. However for that method though, I needed to plug in my computer to wifi though as I was having some sync issues, that I couldn’t resolve.

Hope that helps and feel free to follow up if you have any further questions. I’m not that tech savvy and even I was able to get it to work so should be no problem for you.

2 Likes

Thanks I’ll take a look! I am actually new to the quest family, I have had the osr2 since march and it remains amazing.

At the moment I am struggling to get the pc and quest to communicate via oculus link (the pc is compatible so I am working the troubleshoots and hoping I find an answer before having to work them all again with support).

Oh i see.

Well the benefit of Oculus Quest 2, is that you don’t need the oculus link to get it to work with the OSR, but unfortunately I won’t be able to help that specific problem. Sorry but good luck!!

1 Like

Pretty sure its as simple as openeing up @raser1 's JFP player, and it should auto recognize your players and OSR2 off the bat

Easiest quickest way for Quest 2 is to use SLR/Deovr App and just turn on the interactive remote API in develeper settings

1 Like

I use Deovr App and Release MultiFunPlayer v1.9.1 · Yoooi0/MultiFunPlayer · GitHub Multifunplayer as I have had problems getting JFP player connection to SLR app. Plus SLR app only works on android.

1 Like

Hey this worked for me. I am still trying to figure out how to run it through the JFP (It turns back an error), but I like the XTP player a lot so far.

Thanks a bunch!

Yea a while back i started getting an error too and couldn’t figure out how to fix it.

If you do, please let me know as JFP has a cool boost functionality that i like utilizing.

1 Like

Yeah, thats good there are other players like XTP and MultiFun that work great as well (and actually necessary for the multi axis functions)

I havent had issues with JFP connecting with SLR app, but clearly sounds like some issues arising - whats the exact error guys?

Try DEOVR maybe instead, and typing in sexlikereal in the browser to see if that helps connect (and turning on Interactive remote control in Deovr settings)

Are you referring to SLR Interactive app or SLR VR player App?
SLR Interactive app is only available on android yes, but thats only needed for other toys, not the OSR2

2 Likes

I’ll post the jfp generated error messages later today. There is a good chance its a user error (me messing something up), and it isn’t app specific.

That’s the only way I’ve been using personally DeoVR. Never been able to download standalone SLR app.

But the error I recieved was

“System.Net.Http.HttpRequestException: An error occurred while sending the request. —> System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. —> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.
at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult)
at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar)
— End of inner exception stack trace —
at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
at System.Net.Http.HttpClientHandler.GetRequestStreamCallback(IAsyncResult ar)
— End of inner exception stack trace —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at JoyFunPlayer.SlrSource.B.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at JoyFunPlayer.MainWindow.a.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)”

This was in .txt file that populated in the folder containing JFP 3.0. @jacecolm Is this the same error you received?

1 Like

Hey, I am also getting this error myself now. There seems to be something wrong with the connection. I will look into it.

3 Likes

Yea!!! @raser1 to the rescue.

Thanks, looking forward to getting this issue resolved.

3 Likes

Just ping me like @Realcumber has and I’ll come back from the dead. :stuck_out_tongue:

I think I’ve already found the issue. Please try this and let me know if it works:
https://mega.nz/file/6340RT7I#p5b-9g_xPoI2AxWmUfT3LHvv3LWP4QJ6XBUHPvdL4Lc

If so then I’ll update the JFP thread with this version.

3 Likes

Wow, i wished i reached out sooner. The error was fixed. @raser1 Thanks for the quick solution.

@jacecolm Hopefully this newer version fixes your issue as well.

2 Likes

Thanks raser!.. I had the same error message so I look forward to checking this out later!

1 Like

That is the same i was getting i try the mega link. sorry was a bit late at responding

Looking to make the jump to OSR2 from the Handy. With this setup - are you able to navigate from your Quest wholly? And XTP automatically detects new files being loaded and will load scripts automatically?

With XTP as long as all the scripts you would want to use are in a given folder, that you would preselect when opening XTP, and the video name matches the funscript file. It would auto-detect and play the corresponding funscript.

If it can’t find it and your volume is on, you’ll hear a voice saying to choose corresponding funscript file.

With Joyfunplayer, the other T-Code player on here, you would need to manually drag the script onto the program, which isn’t that difficult.

I’ve never had the Handy but definitely recommend the OSR2

1 Like

My OSR2 Mosaic is inverted. Having trouble figuring out how to switch that around. Any ideas?