Heresphere getting crappy?

I’ve been using Heresphere and Whirligig as my two go-tos - I prefer the Heresphere interface and controls, but the audio wouldn’t match the video on certain vids for no apparent reason. However, lately, I’m finding that more and more videos start lagging or getting frame drop as I get into the video. Seems to be getting increasingly worse over time. Tried uninstalling and reinstalling, but nothing. Same thing isn’t happening with Whirligig, and my computer isn’t having any other issues I can tell. Anyone experienced this/have a fix?

It’s had an issue for me for a while where occasionally a file will get stuck as a black screen unless I start a different video and then come back. I haven’t experienced the sound or lag issue you’re describing though.

Heresphere works find as always for me. Have you installed any new software that might have installed codecs that messes up hardware accelerated decoding?

If the sound drift over time it might be a video issue where the video has been reencoded and the reencoded version slightly changed the frame rate but left the sound unchanged (pass through). It the same issue as sub titles that have timestamps for 30fps but the video is in 29.996 fps or something similar.

Nope, nothing new, no changes in much of anything. The second thing you’re describing sounds more likely, but the same videos are fine in Whirligig, so unless it’s somehow fixing them, I can’t see why that would be, or why this is suddenly happening to more and more videos that I’m playing.

The other interesting thing is it reminds me of why I stopped using DeoVR - different issue of more like skipping, but it was something that happened infrequently at first and then more and more until the player became basically unusable.

Haven’t had any issues here. Probably best asking for help on the discord, the dev is active in there.

1 Like

well i use it for wankzvr streaming, and normally its good but recently its been pretty bad with the stuttering , starting and stopping and loading real slow, even when i bump the video resolution down to 720p it still struggles a bit, and it isnt my internet cuz deovr works flawlessly for me, maybe im overdue an update but im not sure how to update it

1 Like

Are your running firmware version 54 on Quest 2? Apparently this had some WiFi issues and caused some framedrops for me as well.

No, I’m using a PC to stream it through my Quest 2, but I assume that wouldn’t have the same issues as standalone Quest 2 if it’s Wi-Fi-related.

I’m having the same Heresphere issue (frame drops).

Is there a fixed firmware?

1 Like

Also having some issues, but it seems it´s worse with specific videos. I´m decently techsavy but not to that degree. Maybe it chokes on specific codecs or filesizes? Usually having no issues otherwise with that software, and it only started recently. Firmware is up to date, using the pico and a cableconnection.
It´s nothing I can´t endure, just wanted to mention it might not only be questrelated

Sounds like me six months ago, lol. Problem is it has increased in frequency and intensity of the issue from there. I thought about the size factor but some pretty small ones seem to do it now, and I’ve played huge super high-quality vids on there in the past.

I’ve had this issue too. Solved by using XBVR. No more lag.

2 Likes

Looks interesting… I will check it out. Thanks!

I haven’t noticed these issues in Heresphere on my Quest 2 running on the headset with content on my samba share. Maybe its because you are streaming from the PC to the headset have you tried the native version for the headset even as a demo to see if it happens still.

1 Like

No but maybe I will look into that.

Not sure if its related but i had other issue.
Overtime it started happening more often, to the point that it would happen after opening a folder in a file browser.
Thumbnails stop loading and if you try to play a video after that it most of the time crashed.
What I figured out with experience is that, if your library gets bigger and bigger, its trying to load all the thumbnails in subfolders and somehow gets stuck and it goes down hill from there.
Switching to non thumbnail view(List) of files fixed that specific issue for me.
You might still crash here and there if you are doing 8k files.

Yeah, I always did a list, plus I keep my vids on a separate hard drive and transfer to my comp individually the ones I want to play at the time, so couldn’t be that. I’ve actually heard of your issue when searching around and there was some fix presented besides what you did, but I can’t remember what it was. If I come across it again, I’ll link you.

Sorry to revive an old thread, but I have had the same issue the last 4 months. Did you find a fix to the thumbnail problem? Because I find it a lot easier to find the video by looking for the thumbnail rather than the file name, so its kind of a bummer that it hasnt been fixed yet.

I did not look further past the list solution.
In the very beginning before I switched to the list view, splitting the library into couple of folders helped for some time, but down the line its gonna be an issue regardless.