How do I connect my OSR2+ to my Quest 2?

Hi everyone,

After enjoying my Handy for a long time, I wanted to upgrade to an OSR2+. So I bought one and now I finally received my OSR2+… :love_you_gesture:

I’ve already managed to connect it to my laptop and get it working with videos on the PC. I used multifunplayer for this… It takes some getting used to all possible settings and also the sound that the OSR2+ makes… :face_with_monocle:

Anyway, I can’t figure it out, not even through the forum here, how do I connect my OSR2+ to my Quest 2 ? :thinking:

I always use my Quest 2, for VR videos but also for regular 2D videos. This way I have much less distraction and I can empathize better with the video. I also always lie down because I find that the most pleasant experience. That’s not useful at all with a computer screen of course…
I always use DeoVR player and saw that MultiFunPlayer supports it so I was happy. But I am unable to make the connection. :man_shrugging:

Wifi and Bluetooth are on on my laptop, MultiFunplayer open on my Laptop and DeoVR player open on my Quest 2. In the settings in DeoVR, “Enable remote control” is also checked…

In the settings in MultiFunPlayer I see an IP address at the tab DeoVR

→ ‘Endpoint: 127.0.0.1:23554’

What do I have to do with this ?

Can or will someone please help/explain to me how I can get a connection so that I can use my OSR2+ with my Quest 2 please ?
An explanation with other software is also welcome of course.

I’m normally very handy with computers, so I don’t normally need many words…
Thank you very much in advance :pray:

1 Like

tbh if you are trying to play files from your pc I would just recommend a link cable. I have found the only wireless way is streaming scripts on SLR.

1 Like

Thanks for your answer.

I don’t have an SLR account and I want to keep it that way. I also want to use my own videos & scripts and not just the ones that SLR offers. :man_shrugging:

I don’t care if the video-files must be on the PC or on the quest, streaming or not…it’s all ok for me as long as I can see my videos on my quest 2 and my OSR2+ is playing the script.
Just as I’m used to with the handy, but now with the OSR2+ instead…

I also find it strange that there isn’t much info about this on the forum ? How do you all do it then OSR owners ? :upside_down_face:

Well, the short answer is, you don’t do that at all. The OSR2 is controlled via USB on a computer. At no point does it connect to a VR headset.

You’re using MultiFunPlayer, which I don’t use, so I’ll only discuss the basics. MFP needs to talk to the OSR2 over USB, meaning the power cable for the OSR2 needs to be a data-capable cable connected to your laptop. MFP then needs to read the name and position of the video you’re watching from your VR video player. That’s where that “Endpoint” value comes in. The value you see in MFP is what it is configured to use. The software that actually listens at that address and port to serve up video information is the VR software. You need to make sure your VR player is configured to enable that functionality, and make sure the port it is listening on matches that configured in MFP.

Then you click on the little Play button to tell MFP to connect to that address (almost always just the localhost address of 127.0.0.1) and port, and wait for information. At that point, you should see the text underneath the player turn from a red “Disconnected” to a green “Connected”.

Assuming it also properly sees the OSR2, things should just work from that point, provided you’ve come up with a functional mount for your bed.

The big mystery here, for me, is that I don’t know how the Quest 2 works with videos played on a PC. Near as I can tell from a quick search, you need to have a cable connected between it and your PC in order to stream video content to it. Presumably you’ve got that all figured out with the Handy already, but if your solution doesn’t actually let the computer control the video player, it isn’t going to work with the OSR2.

1 Like

I’m pretty sure you can use Heresphere / DeoVR and follow steps from my tutorial (Heresphere with Scriptplayer). Just replace Scriptplayer with MultiFunPlayer:

If you want to make connection between Quest 2 and PC wireless it’s important to type the right IP and port.

1 Like

Thanks al lot for your info and help guys ! :pray:

I already found it and it already worke :love_you_gesture:

It’s actually easier than I thought…
Just connect Quest via Air link (or cable) with the computer, start DeoVR on pc, enable remote control in DeoVR, start MFP, connect everything and you’re done.

Logical actually… :man_shrugging: :upside_down_face:

1 Like

An alternative solution, in case anyone (like me) cannot get 8k VR to play smoothly on their pc using questlink (it is both encoding and decoding some large video streams).

  • Install XTplayer (by khrull) and enable the webclient
  • Install the Deovr native Quest 2 app and enable remote control
  • Setup XTplayer and connect your device (using serial, or connect your SR6/OSR2 wirelessly if you are using khrull’s firmware)
  • Connect XT player to DeoVR by typing in your quest’s IP address in the XTplayer settings

You can now put on your headset

  • Visit XTplayer web through the built-in Deovr webbrowser. You should see your XTplayer library in DeoVr.
  • Turn on external player in the XTplayer webclient settings menu.
  • Play a video

If all is connected Deovr should start streaming the video through XTplayer and your OSR2/SR6 should come alive. The beauty is that all rendering is done on the Quest 2 which makes 8k video with funscripts a seamless experience.

-Bounce

1 Like