How To Quickly Connect Your Sex Toys Directly to Quest 2/3Pro + Pico 3/4 with a Single app - DEOVR!

You can now Directly Connect your Sex Toy via bluetooth with no other app needed besides DeoVR player app!

This is by far now the fastest most convenient method to get connected!

Current Supported Toys:

Current Supported Headsets:

  • Quest 2, 3, Pro and Pico 4 (for Pico 3 you will need to manually turn on BT before opening DeoVR)
  • PC connected headsets to be supported in the near future!

Important: To Enjoy our Interactive Haptics Sex Toy Scripts and all the latest app features, an active SLR Premium + Scripts Bundle is required and as well as the latest updated version of DEOVR app


1 - Power ON your Bluetooth Sex Toy
2 - Launch the DEOVR app, Type in in the DeoVR browser, and Log in
(DeoVR will automatically scan and connect your toy)
3 - Thats it! Now Play any Sex Toy Supported Video and Enjoy Next Level Immersion!


  • Edging Controls are now fully working with latest DeoVR app update version 13.15!
  • To bind your edging controls as desires, simply go into Settings → Controller → Haptics tab
  • more toy specific settings from haptics connect app to be supported in the future!


  • Ensure ‘Scan for devices on startup’ is toggled ON in your haptics settings tab in DeoVR
  • If you are having issues auto-connecting your device, first ensure your toy is ON in bluetooth mode, then click ‘Scan’ next to ‘Bluetooth devices’ in your haptics settings tab in DeoVR


Nice, I just ordered a quest yesterday. SLR interactive crashes on my phone so I will try this out tomorrow.

1 Like

How did it work for you?

1 Like

I had to pair the Onyx+ with my quest to get it to work which wasn’t in the instructions, but other than that it works perfectly fine.

1 Like

Thanks for the tip @Rukker ! - added to the guide :+1:

1 Like

Is there any method to connect handy via bluetooth on Deovr ? I can easily do it on scriptplayer. This wifi connection method is not sufficent most of the times. I have lots of disconnection problem with that but it works on bluetooth flawless. So, if you make it happen it’ll be great.

Just launches a black screen for me

Not yet, maybe in the future - any particular reason Wifi method doesnt work as well for you?

Most people have data plans on their mobile, so consider trying mobile hotspot Wifi connections for a better possible connection

Can you see anything when turning your head around? (logos/icons anything?)

Have you tried fully powering on and off your quest, uninstalling, then re-installing all apps ensuring they are all up to date?

No problem! I think I found a bug. I had SLRInteractive crash a couple of times when my Onyx+ disconnected and I still had DeoVR open (Had the blinking red light issue). The quest said the SLRInteractive crashes constantly and if I wanted to close it. I think it has something to do with the disconnecting, because I could just start it again after that and it worked fine.

I don’t know if it’s supposed to automatically reconnect to SLRInteractive after rebooting the Onyx+ but maybe that fails and it crashes? I would like this feature btw. because restarting DeoVR to start SLRInt./reconnect your device to SLRInt. takes a minute.

@Rukker - not sure why it would crash if the Onyx+ disconnects, but yes, its supposed to automatically reconnect your toy to SLR Interactive, to save you from doing it yourself - I’ll pass on this feedback to SLR devs

This only happens when Onyx+ disconnects? Any reason why it keeps disconnecting?
Have you tried bumping up the Onyx+ number setting in SLR Interactive app to see if it helps prevent disconnecting/locking up?

As a refresher :

Onyx+ device engine degrades with time and too small speed may cause hardware error, when the engine can’t start moving the ring.
In that case increase Your Onyx+ Speed setting several points above 10 in SLR Interactive APP settings until the red blinking stops, then start decreasing that setting number to find the border for your device

1 Like

Yeah I know about the setting. I just had it set to low a couple of times. SLRInteractive only crashed when my Onyx+ disconnected/crashed because of a low speed setting, but not every time.

Now that I have set a higher speed my Onyx+ doesn’t lock up anymore, but I thought I should still mention the crashing issue.

How do I start the SLR interactive app on oculus?

stuck on step 5 → Start the SLR Interactive app first!

Don’t see any option in oculus to start

Hi @Yorrick_Hunt - to start SLR Interactive app on Oculus Quest:

  • when browsing your apps in the main menu, on top to the right is a dropdown menu, select ‘unknown sources’

hey all, I’ve downloaded and logged into the SLR interactive app, however I am not getting any prompts to activate bluetooth.

When I start scanning for my device, it doesn’t show any devices available (using the KEON).

I am able to connect to the KEON to my computer bluetooth and pair the device with the Oculus itself, but just not the SLR interactive app.

How do I enabled bluetooth for SLR interactive app or troubleshoot device scanning?

Just uninstall slr interactive apk and reinstall onto quest 2 to get the permissions allowed / Bluetooth prompt again

(Just make sure Keon is unpaired everywhere else , and flashing blue in ready to pair mode after)

I got the SLR interactive app installed - when it launches it asks for location permissions. Clicking on the ‘settings’ button to take me there just takes me to a black screen.

Going into the permissions settings in the menu i can’t see an entry to give SLR interactive permissions - probably because its an unknown source? Anyone have a solution for this?

did you try uninstalling and reinstalling - that helped others have bluetooth permissions show up again - (ensure you have quest 2 and latest firmware update that unlocks bluetooth capability)

the steps are a good help.

But thel last information: “For ONYX+ Users - You will first need to pair your Onyx+ to your Quest Headset to get it to work” i don’t understand.
Please tell me, what it meens. What i have to do to pair your Onyx+ to your Quest Headset?


Is there a way to adjust the delay without closing DeoVR first? Not all scripts have a consistent delay so sometimes some scripts are off while others are fine.

I tried using my phone to run SLR Interactive instead of the oculus, so I can adjust delay via my phone but for some reason it doesn’t work. The Launch connects to my phone, Interactive is green on DeoVR on the Quest 2, but the Launch doesn’t do anything. It used to work when I used my phone as the VR player with DeoVR but since I switched to the Quest 2, SLR Interactive only works when run on the Quest.

Try these steps to pair your Onyx+ on your Quest 2:

How To Connect Bluetooth To Oculus Quest 2

Enabling Experimental Features on your Quest 2 headset will allow you to pair your device via Bluetooth. Follow these steps:

  • From your Quest 2, open the Settings menu
  • Select Experimental Features
  • Turn on your bluetooth device and make sure it is detectable, then press the Pair button next to Bluetooth Pairing
  • Select your toy from the list of a available devices, and you should be good to go