Is website down? Unable to download any scripts

i randomly cant download any scripts on eroscripts, everytime i click a script link it says page cannot be reached. anyone else have this problem?

Edit: i dont no why but my home internet wont access the downloadable files, it happened at around 3am central time and still having issues.

Is it everything that you’ve tried? I just tried to DL one and it seems to be working fine.

1 Like

Yea im trying to download anything and it still wont work. I try my phone and 2 diff computers for scripts any giving me same message of error not downloadable

Im having the same problem as @greygrey1 Tried it on my PC with different browsers, laptop, smartphone…same result: “page cannot be reached”


weird because i tried my neighbors wifi and it works fine, but my home ineternet says cannot be reached @ITO_Snake

Interesting… do we have the same provider maybe? Im from Germany using “1und1” - you too?

im from usa using spectrum

1 Like

Ok wouldn’t made that much sense anyway :grinning_face_with_smiling_eyes: Im just a tech-noob trying to guess whats the thing we both have in common, especially since @scibbles doesn’t have this problem at all. Weird

Yeah I’ve tried a half dozen random ones and it’s working here

im using google chrome, what bout you? funny thing is i cant even see the pictures of what people posted on here, it shows a broken image pic

Same thing with the pictures. Tried it with chrome, edge and firefox

I was fine a few hours ago downloading scirpts, but now wont do anything. I cleared my cache, reinstalled google chrome etc nothing ! Lol

ok i kind of figured it out, if i change my VPN, i am able to see the images and download the scripts everything is fine now.
did we get IP banned or something? i still cant download on home internet network

having the same issue here. pretty weird. (in Canada)

1 Like

I’m running into the same issue :neutral_face:

1 Like

Everything works fine on my end.

wondering if it’s not an issue with digital ocean.

1 Like

things seem to be working for me :thinking:

Weird I’m having the same issue now, also on US Spectrum :thinking:


I also cannot download with Spectrum…
So I turned on my VPN and now I can download without any trouble.

1 Like