Issues with Kiiroo Keon disconnecting from Scriptplayer

Hey!

I’ve had my Kiiroo Keon for about a week now and have used it a few times with no issues with the scripts on the site.

I use Intiface to start a server and open script player, sync up and the script is working with the video…that is until yesterday.

For some reason the script will start to play, but if I skip ahead to any part in the video or adjust the speed in the settings, the KEON just stops moving with the bluetooth blue LEDs remaining on and not flashing. Scriptplayer continues to say that it’s connected and so does Intiface.

Going through and disconnecting and then reconnecting doesn’t seem to fix it, but occasionally if I do this, sometimes it will work. The KEON works in manual mode so I know that it isn’t broken. I also have uninstalled script player and reinstalled an earlier version and come across the same issue.

Any ideas what could be causing this?

1 Like

I’ve encountered that time to time - maybe try reverting to even more previous versions of scriptplayer latest betas

Alternatively try using SLR interactive? Option 2 => How To Connect Your 147 Sex Toys Including the HANDY, Fleshlight LAUNCH, Kiiroo KEON or ONYX+ For Interactive 2D and VR! Step by Step Guide

Should be a more stable connection that route and there should be a hopefully better optimized playback algorithm incoming for Keon there

1 Like

Unfortunately I don’t have an Android so can’t use option 2!

I’ll try reverting to an even older scriptplayer and hope that fixes it, will keep you posted!

1 Like

Still no luck with this!

I’ve tried the beta, current version and the v1.0.5 version from 2018.

Could this maybe be an intiface issue? I’m not sure what could be causing this as it’s seen here:

I then also will connect via Scriptplayer which will then connect to Intiface and the Keon. I will then click ‘search for devices’ sometimes if it doesn’t connect automatically:

image

There is a jolt so show that the device has connected and the blue leds stop flashing and stay constant meaning it’s connected. After this, I load a video/script and the KEON doesn’t move at all.

This is super frustrating as I’ve only had this device for a week and is quite pricey if its broken already. Not sure what the next steps are so any advice from the community will be greatly appreciated.

Thanks!

Could it be a range/speed problem? I know when I try to change it to 0-100 my keon won’t work so I put it on default settings on the latest version and it fixed it for me.

good point and thing to try - there technically isnt a point that is 100 - only 0-99

I did start to get these problems after I started to mess with the range/speed in Scriptplayer, so it could be what possibly caused this issue.

However, looking at Scriptplayer, the settings don’t seem to match what you and @Realcumber are saying and are sat between 5 & 95.


Do you see anything that could be causing it in those images?

Thanks for your continued help!! :slight_smile:

Your settings look fine - Checkmark “Show heatmap” and “show script positions” to make sure that you can see your script is properly loaded
-Drag and drop your script onto scriptplayer window to ensure its loaded too - you should see the heatmpa /stroke display if it is

  • What led colour is showing on your Keon when connected? (Should stay lit blue not flashing if properly connected)

I got this fixed earlier from help on the Buttplug discord. It was something to do with Intiface not downloading the correct file from their servers.

They have no idea why it was happening and we got around the problem in an unconventional way but its all fixed now.

Thanks again for your help!

1 Like

I do have same issues with keon.
@ilfdsm2: What’s the workaround? Can you explain the “unconventional way” :wink:
Thanks in advance!

1 Like

@Anti1000 Do you have issues when uninstalling Intiface and then re-installing?

This was the issue I had. If so I can point you in the right direction.

I don’t believe it’s your issue, but want to comment for the archive.

If you have issues with your kiiroo sputtering, not matching the inputs, or general connectivity issues, make sure you disable the connection from windows bluetooth and that your computer is connecting to kiiroo through your usb dongle.

1 Like

I only use my KEON through Windows bluetooth, I never use a dongle.

I mentioned this elsewhere, but should probably mention here:

Something with the current version of ScriptPlayer seems to be preventing me from using my Keon with it. Much like described above: It can connect to intiface/buttplug fine, it finds the Keon fine (Keon homes to default position), but then it doesn’t react to any script motions, or only reacts to the very first.

Interestingly, Syncydink works absolutely okay, so I suppose it could be intiface’s non-SSL server not behaving correctly, maybe?

Things I’ve tried:
1.1.0 release of Scriptplayer
Newest Beta release build of Scriptplayer
Newest “pre-release” build (1.1.1) of Scriptplayer
Newest version of Intiface (20.0.0)
Older version of Intiface (19.0.0)

as of so far, nothing gets Scriptplayer to work with the keon, but Syncydink works with both versions of Intiface just fine.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.