JoyFunPlayer 4.0 - OSR (TCode) Player

10/10 Would DL again.

I’ve been using racer1’s software for years now and honestly if your looking for something that is extremely intuitive, feature packed and easy to setup, look no further. Everything he has shared with the community is gold.

I don’t know if there are any plans to update JFP in the future, but if there are, I’d love to see ability to modify the controller layout and stick deadzones through a config file or something. (just a thought. :smiley:)

Thanks for your many contributions of awesome shit. You are truely a legend!


@raser1 as always…EPIC bit of software.

Got a bit of an odd issue and hoping from some guidance from you or the community?

JFP version 2.0 worked and recognised the OSR2+ but would bomb out if i tried to login to SLR (but would work with local scripts) because of this i have mainly been using Kruls XTplayer and manually grabbing the script.

I have noticed your new version now supports full streaming of scripts to the OSR from SLR and Quest2 VR.

Happy days!! or so i thought, everything looks like its working, can see the SLR script load and sync happening in JFP 4 but after what seems like a little “init” when launching JFP the OSR doesn’t move. The player looks like its doing all the right things just not moving the OSR?

Any Ideas?

Also… what controller would you recommend, old school xbox or can we use the cordless one?

Cheers, in advance :slight_smile:

Thanks @rrunes @grl :smiley:

@grl Please check if Mode says ‘Script’. Otherwise please send me a screenshot of the app running (here or in PM if you want) That’s the easiest way for me to check what’s happening.

Any controller with the necessary buttons would work, I prefer the wireless one.

Hi @raser1,

Yes the mode comes up as script, connected to SLR, just doesn’t show a T-Code connection, give me a min and ill grab a screenshot for you, happy to switch to PM’s if your prefer not to clutter up your thread?

Hey sorry for the late reply.

You probably have to install the Arduino IDE depending on your toy:

It should find it automatically if the USB driver has been installed.

Hi F86K,
I also have a Venus, and have just started thinking about doing exactly what you’re talking about, changing from the DC motor to a stepper, and integrating funscript. Can you share details of what you’ve done and how it is working? Thanks.

Oh I forgot to mention that my setup is DIY lol ($946 is steep, just bought the liner and diaphragm from them) but the principle is the same.

  1. Replace original motor with a stepper (or ODrive-powered/other control for a servomotor if you want to avoid stepper resonance noise).
  2. Modify the Arduino TCode controller to control your motor which is simple trig problem, inverse cosine to determine what angle you need to rotate your motor to depending on linear position. With a stepper you’ll need to have a limit switch or some other way of calibrating the position like a button you press until the stepper rotates to a reference rotation like 90°.

The cheapest solution ($50-70) is just getting:

  1. Arduino
  2. Stepper driver (I recommend TMC5160, it’s mostly quiet and can handle NEMA 23 and some NEMA 34 steppers)
  3. Probably want a 24V power supply so the stepper doesn’t run out of torque at higher speeds

I’ve since switched to an ODrive+RC brushless motor+encoder setup which is quieter and faster, but that is a lot more expensive (ODrive price has increased beyond $200) and it’s more components and programming to deal with.
As it relates to JoyFunPlayer, you should also find something similar to “Filtered position control” as described on the ODrive webpage:
I never got to implementing that for the stepper setup but it should prevent jerky raw input from going through to the stepper and making noise

For me, it isn’t loading any scripts on SLR. It finds the video, but not the script.

I bought premium+scripts and accessed the videos with the Interactive icon, but it doesn’t work.

The JFP app shows that DeoVR and SLR are playing though, and like I said, JFP found the video, but not the script.

What might be the problem?

Only SLR should be active. Try disabling ‘Remote control’ from Deo settings.

Also make sure you’re running the latest version.

I have Win10 and it has an attitude about new programs. To get several of the ones here on this site I have to run the program as Administrator the first time and accept any messages regarding trust of the program.
After that they run perfectly.

If I do that, yes, only SLR is active, but then it doesn’t even find the video, much less the script.

I opened both SLR and JFP programs as Adminstrator too.

EDIT: I scrolled through this thread and found out there’s a new version. Now it works, thank you.

1 Like

New OSR owner here, trying to play local funscript. I should miss something, but I only succeed to play the main axis, pitch and roll stay fix.
Did I miss something?

Hey @raser1! Thanks for the amazing work integrating SLR! Is it possible to use local scripts with SLR videos?

Sorry, I’ve just read this :stuck_out_tongue:

1 Like

Hi i try to launch MPV player but it doesn’t do anything command prompt shows up and crashes tried the latest mpv player version any ideas?

npticed mvp player is not in the most recent jfp\

is there a way to reverse the movement of the osr2+ ?
SLR is the only “app” that is out of sync or moving in reverse, if i try via Faptap its all in sync

Is there a reason why I can’t adjust Pitch or Roll settings in 4.0?