Keon does not connect to scriptplayer

I’ve spent the past day or two looking at tutorials, guides and other forum posts about how to solve my issue but still havent had any luck. Scriptplayer connects to initface perfectly but when i scan for devices, nothing connects. Can someone help me? I use this dongle https://www.amazon.com/Plugable-Bluetooth-Adapter-Compatible-Raspberry/dp/B009ZIILLI

What i do:

  1. Open intiface and scriptplayer
  2. Turn on keon (blinking blue)
  3. Start server on intiface
  4. Connect to server on scriptplayer and scan for devices.

Nothing happens after that. Something else to note is that i dont pair the device to my pc bluetooth while doing it but when i do try to do that it only connects for 3 seconds at most and my keon goes back to blinking blue but on my pc it says paired.

Something else ive tried is to connect to faptap.net with my keon but it isnt able to find my device via bluetooth. I have a couple android devices that ive tried faptap on aswell but bluetooth still wont connect. Regular bluetooth connection outside of chrome and faptap works perfect though.

I have same setup except my motherboard has built in bluetooth. My order is:

-Switch Keon on first.
-Launch intiface and scan for Keon. Once hear Keon move I do disconnect from server I think it is as mentioned in intiface you have to do before can connect to scriptplayer.

  • Then open scriptplayer and connect to device.

If you do not get Keon to move when scan from intiface then must be bluetooth problem. When first connects the Keon only moves small amount but indicates it is connected. Hope that helps?

Do you go to the server status section on intiface or the devices section when you scan for the keon? Thanks for helping me out!

You don’t need to connect it directly to Bluetooth. That’s your problem. Use scriptplayer via initiface.

Turn on keon
Open initiface
Start server
Open scriptplayer
Connect to buttplug server
Scan for devices

Again, do not connect windows Bluetooth like you would a keyboard.

I’ve tried doing it both ways, connecting my keon to bluetooth first and then launching intiface and scriptplayer and not connecting to my pc bluetooth at all. Both ways don’t work.
I think it might be an issue with the bluetooth because when I try to just connect the keon to my pc bluetooth it says paired but the lights only stop blinking for a couple seconds and then go back to blinking blue but its still paired.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.