Kiiroo Onxy+REALM keeps disconnecting, speed/range issue?

I got an Onyx+ REALM edition a month or so ago, and I’ve had a lot of issues with it. For one, there have been a few times when trying to pair it completely freezes, and won’t turn off. I have to leave it until it eventually turns off, hours later. The biggest issue I am having is when I have it hooked to the computer and I am trying to use it with ScriptPlayer. I have intiface running, have the device connected, and as long is there is constant action, it is fine. However, if there is a pause in the action, or even sometimes if there isn’t, the light on the unit starts flashing red. According to the manual, it does that due to low battery, but it will do it repeatedly. I can turn it off and back on and it will reconnect, and start working again for a time, but just keeps repeating the same issue. If I connect through my phone and FeelConnect, it works with no issues. Has anyone else experienced this problem? In the guide, I did find some mention of the flashing red light, but it said to adjust the speed in the SLR app. I tried adjusting both speed and range settings in ScriptPlayer, but can’t seem to get it to work. Can anyone else recommend settings for the Onyx+ REALM, or the Onyx+, that has worked for them?

Thank you.

I can’t offer any help, but I just wanted to say I just got my Onyx+ today and I’m hitting this as well. I’m using ScriptPlayer + Intiface + DeoVR + Valve Index. Onyx is connected via Bluetooth to my PC (although not through Windows, just the ScriptPlayer app). I’m running local video files with local funscripts.

Basically, the exact same experience as you though. Sometimes everything is fine, but it will randomly go to red flashing light. At first I thought the device was defective but it is fully charged. I feel like problem lies in the funscripts or how scriptplayer is handling something there. It does seem to happen a lot when there is a break in the action. I haven’t tried anything through my phone or FeelConnect app.

Just curious, what version of ScriptPlayer are you using?

Best to connect through Haptics Connect app and Deovr guys → complete guide here → Interactive Sex Toy Scripts Complete Help Guide (Kiiroo,Vorze,Handy,Lovense)) - SLR community forum for the best VR porn videos

Check ‘Option 2’

Onyx+ is known to have this blnking issue, but theres a fix → In Haptics connect, theres a specific Onyx+ setting you need to adjust, as every Onyx+ is slightly different :

From the guide:

Keep in mind Onyx+ Realm is not yet supported, hopefully soon though, so just Onyx+ (non Realm edition will work)

Hi there, I had the same problem with my Onyx+ (non-REALM). Check out my post here on how I fixed it.

1 Like

Realcumber,

I have tried this, but the blue icon for the toy does not show up in the VR app. Is this due to the REALM not being compatible? I didn’t realize it was a completely different product when I bought it, thought it was just a visual change, and came with the vr headset. You said it will hopefully be compatible soon, is there somewhere I can check on that, or are you aware of active work being done to support the REALM edition? Thank you so much for your feedback.

I tried the guide that you suggested (well, the one on the eroscripts site, which is very similar), but I hadn’t seen the Haptics connect app, I will try that. The other issue I am running into when trying that method is I cannot enable the "Connect to SLR Interactive) toggle because you have to have an account, and I do not.

yes, it has a different Toy ID by Kiiroo, so needs to be coded for separately in the SLR/Haptics Connect App

It will be announced if/when it gets support added, just not sure when that will be unfortunately

Please help!
Even when i set the speed to 100, i still get blinking red light between and during scenes
Onyx+

you shouldnt need to go that high - try a lower setting - something like 15 or 20 and go down till you find a setting where the blinking eventually stops

Started from 30…check all the way down to 0
still blinks :sob:

Hi all,

I don’t use the VR app but instead play videos locally on my computer via whirlygig, but I am able to sync my Onyx+ Realm to script player via my PC bluetooth, and it works flawlessly.

it took me a bit of trouble shooting to get Intiface and Script Player to recognize the incoming bluetooth connection from my Onyx Realm +

instructions on how to do this in my other post

For me it stops blinking red near 90+

Literally tried EVERY setting…0%-100%… no luck :confused:

Thanks for your reply, but I didn’t have that issue. My Realm actually showed up in Windows just fine, and was able to connect in ScriptPlayer. I started to follow your guide, but realized mine was showing up as Rey, which was one of the default names.

Yes it seems that an update has broken the onyx+ control. I have used SLR interactive instead and it was ok with a setting of 24.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.