EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

Launch Bluetooth no longer connects to script player

Yeah so suddenly my launch refuses to connect to Script player. Yes I’ve tested to make sure the bluetooth on the launch works with other apps. It successfully connects to phones and other computer services but just infinitely blinks when trying to connect through script player

Hi EyeofThe.

Few things to try.

Make sure the launch isnt paired by bluetooth to another device like your phone. I know I have to turn off the bluetooth on my phone or I get a connection error message.

Also make sure your bluetooth is on but not paired to the launch on your PC.

Hope that works.

1 Like

I’ll try turning the bluetooth on my phone off but i think ive tried just about everything else so far.

I had the same issue. Most likely your bluetooth on launch died. So it’s better to look for alternative devices.

Mine did the same thing 2 weeks ago. But i downloaded Qdots Initface desktop (aka buttplug) and connected with that instead. Then after 2 days i could connect like normal again, so the launch or scriptplayer were probably just stuck trying to pair with something else.

1 Like

I’ve recently started seeing this as well, and what is happening to me is the Bluetooth adapter I’m using likes to change its driver (likely something with the newer Windows updates). What I do to fix it is open Device Manager (assuming you’re using PC, devmgmt.msc). Sometimes it will not show under Bluetooth adapters - in this case, you can usually find it under the “Universal Serial Bus Controllers” section (can sometimes be a little tricky to wade through everything to find the correct device - if you can’t find it unplug it, expand the list, plug it back in - the “new” device that wasn’t there before will be the adapter). Other times it will still show under the Bluetooth seciton; however, it will be Bluetooth Radio, CSR BlueCore Bluetooth, or some other such thing. In both cases the solution is the same… Right click the device, Update Driver, select the Browse My Computer for Drivers option, then the Let Me Pick option, select Generic Bluetooth Adapter. Adapter is the important part. I know this is fairly techy - if you need further assistance trying this option feel free to DM me.

Edit - I remembered one other thing to look for… If your motherboard has built-in bluetooth (the type that doesn’t work for Launch), make sure the onboard is disabled and only the USB adapter is enabled. I’ve hit this snag as well. Additionally, the advice about making sure the Launch isn’t paired is a good place to look.

1 Like

Do you know if the launch has a way to manually connect to the Initface Desktop app through the serial port device option. If so how do I go about doing that?

Tried everything here unfortunately still not working. Even reset the PC after the driver change to adapter.

O wow actually I just noticed, when I change it over to Adapter the computer immediately changes it back to Radio. Is there any way to prevent my computer from immediately overriding my choice?

I’m starting to think I need to buy a better USB Bluetooth for my PC. My launch has zero issues connecting to my phone but absolutely refuses to connect to my pc or even appear on my pc’s list as a device.

I had a similar issue. i think it lit blue showing the connection but it didnt actually work(?)
either way, i realized it was briefly after a buttplug update so i went back to buttplug Intiface Desktop version 17.0.0 and that fixed my issue! i never upgraded again sense.

also be aware that launch doesnt do well with USB 3.0 (blue) outlets

Im pretty sure the serial port device option are for other toys. so you are stuck using bluetooth with the Launch.
I havent used initface much, so maybe you should ask @qdot for a better answer.

If you are having trouble for it to connect, do it in this order.
Initface: server status–>start server
Script player: devices–>buttplug/initface–>connect
Script player: devices–>buttplug/initface–>scan for devices

1 Like

I’ve had the same thing happen to me before, I’ve had to download new drivers for my adapter and change script player to version 1.1.1 Every now and then it will refuse to connect but just need to shut everything down and restart. I think it must be a windows update issue or some other bluetooth source interfering.

Thanks everyone for the input I’ll keep trying everything I can and will update if and when something works!