Launch suddenly has reduced range

I’ve been using the Launch with the ScriptPlayer for years without problems. Since yesterday, it doesn’t follow the scripts accurately anymore, sometimes it doesn’t go all the way down, or all the way up when it should, as if the range is reduced. The Launch worked FINE when I tried it in manual mode (went all the way up and down, fast and slow). I also tried telling it to do a sawtooth pattern through ScriptPlayer, and it executed it perfectly.

Here are the things I’ve tried so far:

  • Restarted Launch and PC
  • Tried it on a full charge
  • Checked that the range was not limited in ScriptPlayer
  • Tried multiple scripts that worked fine in the past
  • Updated/reinstalled ScriptPlayer
  • Tried old versions of ScriptPlayer
  • Checked my PC’s bluetooth connection with other devices (works fine)
  • Opened the Launch up to see if anything’s broken or stuck (even though it worked fine in manual mode) - everything seemed fine
  • Sprayed some WD-40 on the moving parts

If anyone knows what might be the problem, please help. Thank you!