Launch wont connect to Script player!

Hi guys,

Not sure if this is the right section for this but i am having trouble connecting my launch to script player. It used to connect no problem through intiface/buttplug but now when i scan for it on script player it doesnt find it. I tried to use Syndylink from my pc and that also doesnt find the launch. The weird part is i went to syndylink on my android phone and it was able to find it and properly activate the launch. Has anyone else experienced this or can think or a fix?

P.S I tried reinstalling my bluetooth drivers and i tried a different computer (which it also used to work on) and it still did not work. Any help is appreciated thanks.

What OS do you have on your PC? Do you use the internal Bluetooth and is that Bluetooth Low Energy (BLE)?

2 main reasons for this problem (afaik)

  • BT Dongle died
  • Corona-Tracing App nearby (The tracing api on Android and iOS is also BLE based and quite spammy - latest build/beta of ScriptPlayer has a BT filter that fixes that)

I have windows 10 on both machines

Thank you, I tried the beta version and this also fails to connect to pc. I have no idea why it will connect to android (syndylink and feelconnect) but not anything pc related. Also i tried the dongle on other devices and it seems to work and my second machine is a laptop with built in bluetooth which i also tested and it was working.

I hope I don’t jinx you, but I had a similar problem with my Launch shortly before the Bluetooth died. It started acting quirky and within a few days I wasn’t able to connect to any device at all. Kiiroo did honor the warranty but it was a long, drawn out chore to get them to do so. I took the refund and bought a Handy. It’s not hands free out of the box and it’s still very much a work in progress, but if allows longer and quicker strokes than the Launch. Something to think about if your Launch fails.

Having the same problem starting today. Blue light blinks but script player cannot connect. I will occasionally try new versions of script player but I am guessing my launch BT is dead…

have you tried connecting it to syndylink? it diddnt work on any computers i own (which i know have their bluetooth working) but it did when i tried it on my phone.

No, but I will look into that!

I also noticed that when I “tried to connect to buttplug” it can’t. Do you need a device in order to do that or is that indictive of something else? I never pressed that button before until just now trying to troubleshoot.

If your phone or PC bluetooth can see “Launch” when searching for devices, and the launch is on searching too, then basically the launch’s bluetooth is dead :frowning:

no real fix, just contact kiiroo for refund or replacement for their new Keon

Its exactly what happened to my launch, which prompted me to get the Handy. I should really just toss my old launch out, I still have it in the box tucked away lol

I have 4 launches lineup, with my fleshlights in their case inserted as a drying rack :rofl:

1 Like

Yeah… Feel Connect can’t find anything…

Weird… it magically started working with scriptplayer again today…

1 Like

I had problems that I thought were Bluetooth hardware related, thinking either the BT 3.0 USB dongle died or maybe the Launch was failing. I eventually discovered I had taken a MS Windows update that borked things. I had to remove the BT USB dongle, uninstall the hardware in Device Manager, uninstall the Windows update. I then reinstalled the windows update (yes I know it seems odd but I wanted it installed while there was no BT USB dongle in Devices), then I plugged in the USB BT dongle, and let Windows detect and install default Win10 drivers. DO NOT DOWNLOAD AND INSTALL CUSTOM DRIVERS!
It worked. I also added a 3 foot long USB extension cable, and added the dongle on the end attached just 12" from the Launch on the underside of my desk with velcro. It seems to work so much better.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.