My script is not working

i made a script using the blender plugin, my first script works but the 2nd one that took days is not working. is there any way to find what is causing the issue?

the name and location of script is correct and the creation method was the same as the first so in theory it should work

video link

Long Slow and Sexy POV Blowjob Experience With Cum on Glasses.funscript (91.4 KB)

The numbers in the script are completely off.
[{“pos”: 0, “at”: 0}, {“pos”: 10, “at”: 3612592}, {“pos”: 0, “at”: 7298910}, {“pos”: 10, “at”: 10911502}, {“pos”: 0, “at”: 14597820},
This should translate to points around 0 min, 60 min, 121 min, 181 min and 243 min. So when you load this with your script you get one point a the start and the next is after the video ended unless the video is over an hour long. I have no experience at all with blender so I can’t tell what went wrong. If you are using Windows 10 then I recommend that you try OpenFunScripter or JoyFunScripter instead (see software section in this forum). OFS might even be possible to run with Linux. I’m unsure about the status on that though.

+1 to using something other than the blender plugin. There are newer, more focused applications to do what you want. Either Joyfunscripter or Openfunscripter will be nicer to use.

Out of curiosity, why did you start with the blender plugin? I am guessing there are some tutorials that new users look to that leads them to this as you are definitely not the only one to choose to begin this way.

Thank you
i’m not sure why it’s so far off as on blender the video and script both show a start at postition 0 and scrub in sync together, i have gone wrong somewhere. i will try the software you have mentioned

i started with blender as it seemed easier when i was looking at the very limited info about creating scripts, download blender, add pluggin and start. some of the files i’ve grabbed from GitHub are overly complex, run this cmd and add this in regedit and do another 6 things and it might work and if it doesn’t dig through forums for hours and you might find answers. i think as a new user you go around in circles a lot just trying to get something that works and for some people like me blender has been the only thing that has worked. it’s not until you join a community like this that you get an idea what to look for

It has a playtime of 67d 9h 0m 12s.
If I devide the timestamps by 4500 it gets down to 21m 33s

Untested in terms of sync but at 21m36 she did the last touch so this is very close.
Maybe you can just scale it corrent without doing the whole script again.

Clipboard7462.csv (33.5 KB)

Start reading this:

It might seem like a lot to read, but sift through the guide and you will find that it is quite easy to get started with either OpenFunScripter or JoyFunScripter. The software are very similar in their core functionality, but there are also differences. Try them out and use the one that suits your needs. Both software can be found in the software section in this forum. Be sure to read any installations instructions. Not installing pre-requisites is the most common reason if they are not working properly.

I found the issue, blender is loading that video at 270ish FPS with a high frame value, had to set FPS to 59.94 and frame value to 1 and it synced up. I went through the script and fix the less than 150ms movements which was better than starting over, I’ll check it and upload this week if it worked. Taking community advice and trying joyfunscripter for the next one

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.