EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

Openfunscripter install help?

Hi i am trying to get into scripting and have dloaded openfunscripter and the extra microsoft enabler but cannot open videos , i get this message?

Have you tried older version of OFS? 1.2.0 was a big change so there might be things that won’t work on some platforms, you might want to try something prior to that, maybe 1.1.9 will work: Releases · gagax1234/OpenFunscripter · GitHub

There was similar problem when OFS showed up first time:

nope that didnt do it
went back to 1.19 same error i am only downloading the exe file what is the 7Z file and other downloads there?

7z is a zip-file (7Zip) of what the exe installs. The last file is for installing on the Linux operating system if I remember correctly.

What graphics card do you have?

I think it’s just the i7 graphics processor

You didn’t go into the options and forced hardware decoding right?
I don’t understand why it would try to load nvcuda.dll…
By default it’s supposed to use the CPU.
It’s not part of my code so I have limited control.

Can you try this version: AppVeyor
I changed it so it explicitly sets hwdec=no (this should be the default already).
I actually don’t expect this to work but I’d love to be proven wrong.

Well i can confirm you have been proven wrong gagax, that worked a treat, hopefully i will be able to contribute to scripts on the site now !!.
Thanks very much for sorting it

wtf. I’m glad it works though.

1 Like

New OFS install here 1.2.1 (OFS-x64_Windows_master-806a15051c113128b3723f326b29370c743cd969.exe). It’s giving me this error (Cannot load nvcuda.dll) right when it starts.
I did not try an older version yet. I wanted to see if I could set hwdec=no first but I could not find the config file. Where is it? Sorry for the noob q.
Edit: I thought it was frozen after giving the error but it’s actually very very slow. I went to the preferences menu.
image

Look at this post a few rows up and try the version that gagax123 linked to. That solved the other user who had an issue with nvcuda.dll.

No unfortunately that did not work for me.
image
As for the graphics card I have an older machine with Intel HD Graphics 4000

@imratore
First make sure your graphics drivers are up to date.
If that doesn’t help try creating an “mpv.conf” file in %appdata%/OFS/OFS_data/mpv.conf
and put vo=vaapi in it. documentation
When I do that nothing works because I have no Intel integrated graphics but maybe it works for you.

Thanks for the response @gagax123. I tried a lot of different things to try to get it to work and including in your release notes - Added ability to add a mpv.conf to the application directory. So I had added a mpv.conf to the OFS dir & was trying that. The correct directory helped :slight_smile:

However it did not work. The closest I seemed to be getting anywhere was with vo=gpu hwdec=d3d11va which popped a player in a separate window.
Tinkering with it led me to the real problem. Regardless of the options, the OFS window is not refreshing (which earlier made me think it was frozen) ie when I use the menu, there is no dropdown - the screen appears frozen. Or when I hit the play button, nothing seems to happen but I can hear the sound of the loaded video so it’s actually playing but not updating the screen. The OFS window updates when I place another window (browser or Explorer) on top of it and then switch back but I have to continuously keep doing that.

Anyway, I do not want to waste too much of your time with one person’s issue with older hardware. But if you do have an inkling of what might be the problem let me know. My drivers are up to date & the C++ redistributable ver is 14.24.28127.

Oh and I also stumbled across this cannot load nvcuda.dll · Issue #5 · Raveler/ffmpeg-cpp · GitHub
Thanks!

Honestly no, there’s nothing I can do.
It doesn’t help that mpv is a little Linux centric maybe this wouldn’t happen if you would use Linux :sweat_smile:
I’d say it’s a bug in mpv on windows but I havn’t found any reported issues on github so I’m just assuming.

There’s also a software rendering a backend as an alternative to the opengl rendering that I could use but that would that be a couple hundred extra lines of code with no gurantee that it would help.
I would prefer not to.