OSR2 Motion inverted

My OSR2+'s up/ down motions are inverted, and I’ve opened it up to check the servo wires and they are in the right place. Looking through similar topics, I suspect the SR6 mode is enabled but I have no idea how to disable it, or what “web panel settings” are. Can a kind soul please tell me how to do that? Thanks!

1 Like

I had that happen with my SR6. It was reversed wires in my case.
If you are running Krull’s firmware on an ESP32 board, you can got to your available WiFi list on your computer and see if there’s a wifi network with Tcode in the name. Connect to that, and then open a browser and enter the ip address That will take you to the web UI of the device and you’ll be able to quickly see if the SR6 mode is enabled. If you can’t do that, you might need to download the Arduino IDE ( Software | Arduino to install Krull’s firmware, OR download the flash tool ( Tools | Espressif Systems to install Tempest’s firmware. With the latter method, you can actually view the code and see if the SR6 mode is set to FALSE or not. But I would bet on the wires being backwards because I dealt with the same issue.

I’m not sure what firmware or board I’m running as I’ve bought my OSR pre-built off of @M0SAIC. I have dm’d him but haven’t heard anything yet. I’ll look into the flash tool once I get that figured out. How would I know if the wires are in the wrong place? I’ve taken a photo of my wiring and traced the orange wires from the servos. Here’s a picture of my unit.


Dmed sorry for the delay.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.