Osr2+ not moving when running scripts

Hi, All Long time lurker of the forums.
I have recently purchased a OSR2+.
I have downloaded the multifunplayer and mpv I believe I have figured these programs out, however, I connect it etc it says connected com port 3 I installed the drivers and everything but nothing happens when I run a script. the driver I have downloaded is CP210x-Universal-Windows-Driver.
Is this right or am I doing something wrong.
.I Also I purchased said device from your hobbies am I missing something or is there no power button on this device thanks all hope I can find an answers I am looking for.

Update. new power supply arrived and it didn’t work so I am not sure how to proceed I was thinking that it is probably due to the fact that country’s in the pacific run on 240v not on 120v so maybe it over volted and fried the esp32 I am not too sure as the power supply provided says 120v-240v meaning it’s a transformer power supply so there should be no issues.

Have you connected MFP to your desired video player? It should look like this if setup correctly:

Also @M0SAIC.

Indeed I have connected it like that it says mpv connected and serial connected the the script heatmap shows and everything just no movement.

Note the fans are running on the unit when it’s plugged in just no servo movement or anything like that initially when I plugged it in it would occasionally move around but as soon as I installed the driver that stopped.

I also tried installing arduino ide but it would not auto detect and there is like a million and one esp32 configs to do so I was unsure which one to do to test if it was working.

Send @M0SAIC a private message and they should be able to help you diagnose the problem.

Meanwhile one way to make sure the COM port your using is the right one is to see if it vanishes from the select-able list when you disconnect it. (just make sure to refresh it) Though the device should also do a jerking servo movement when you connect to it.

Additionally maybe seeing if the device moves or shows up on intiface central might help too with seeing the problem, I posted a guide here: OSR2/SR6 to Intiface Central connection unofficial rough guide Since the program itself shows a debug log and if you follow the steps in the guide you should end up with moving the OSR2 up and down and be able to connect to it if you have the right COM port and nothing else is messing up.

I just tried this method and it seems to connect to interface central so that is working It looks like it’s working at-least no response when I turn on Oscillation though.

Now onto the game it does not seem to want to connect in the logs it seems to be trying to connect but it just won’t connect for whatever reason.


Yeah…hopefully all this information is helpful for M0SAIC when you contact them privately as all this is tell me that somehow the device isn’t receiving/understanding the signals your computer is sending to it. Since it is sending something to your computer.

With the Setaria player bit, the problem there is with that talking to Intiface Central here is what my settings page for Intiface looks like:
Just incase because mistakes can happen, you do keep the Intiface server running but not scanning when you start up the player right?

that’s Correct I was doing that when I was trying to connect and my settings also look the same as that.

I’m beginning to think it might be a short because the Initial time I plugged it in and it seemed to twitch occasionally and it also reset the position of the servos back to the neutral position but right after that initial point it just stopped doing that.

side note: just for context this was before I installed the driver but I tried reinstalling the driver to no avail.

Yeah that constant twitching is suspicious since mine (SR6) after turning on the power twitched as the servos got into position slightly and then another final twitch when connected to in multifunplayer.

Have you done any work with electronics before like changing out parts in your computer or similar? As you could under M0SAIC’s help open it up and check the internals and maybe fix it. I highly recommend having a good magnetic screwdriver and good selection of change-able heads for it. (H3 and H2 heads are needed for the outside screws for mine and I think a PZ/PH head if I remember roughly correctly)

I have have sent a Message to M0SAIC about the troubleshooting.
I work in the It field so yeah I have the tools to look at it.
I also opened it up to look inside I made sure all the connections were secure and I didn’t see any burn marks but I’ve never really tinkered with stuff this small used to looking at servers and pc’s not arduinos and raspberry pi’s.

My assumption is that if something this small shorts there would probably be nothing visible correct me if I’m wrong?

No idea I haven’t had experience dealing with anything smaller than a computer/laptop and the only things I’ve had to do for my SR6 is replace a servo and switch out the top arms. The servos were the most annoying out of the two but doing the entire board I know would suck the most since in my head that’s the equivalent to swapping out motherboards in a system. (All I know is you need a PZ0 head that’s long and thin for it’s screws)

I think any marks might be under the wire connectors or very tiny on the board. Oh yeah what lights turn on and at what points? I think I get red and blue though no idea as to where on the board. (although no idea if this changes anything but hey means M0SAIC has more info although potentially useless)

that looks like a power problem, i had the happen with twitching. once I bought a new power supply it fixed

only the red light no blue light though.

Yeah that’s what I am thinking but I’m just not sure maybe it has to do with the fact that I need an Au plug ac adapter and I live In Aus so the cable is different I assumed that all ac adapters are transformers though meaning that wherever you are in the world they should work the same so long as you have an adapter.

ive got the same issue, do we have a solution yet??