OSR2 right servo not moving

I’m setting up the osr2 and the right servo that’s plugged into pin 3 doesn’t seem to move. It works when I plug it into pin 8 so I know its working. And it shouldn’t be an issue with the board either since I’ve tried it with two boards and I get the same issue. Has this happened to anyone else before?

T-wist feedback goes on digital pin 2
#define Servo1_PIN 8 // Left Servo (change to 7 for Romeo v1.1)
#define Servo2_PIN 3 // Right Servo (change to 4 for Romeo v1.1)
#define Servo3_PIN 9 // Pitch Servo (change to 8 for Romeo v1.1)
#define Servo4_PIN 12 // Valve Servo
#define Servo5_PIN 10 // Twist Servo
#define Vibe0_PIN 5 // Vibration motor 1
#define Vibe1_PIN 6 // Vibration motor 2
have you pressed the reset button on board and uploaded newest ino to board ?may help

Resetting it doesn’t seem to work and the pin assignment looks exactly like what you posted so it should work, not sure why.

I fixed it, thank you. I was using the wrong pin because there were two pins labelled 3.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.