EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

Red led issue after migrating to Haptics Connect

I recently migrated from SLR Interactive to Haptics Connect on my Quest2. When using SLRI I had the slider around 19/20 and never got the red light issue. I don’t know how the slider in SLRI relates to the one in HC but 20 did get me the red light issue (on slow parts) so I now have it set to 40. This works fine when there is action but every time when the script has no action (if only for a few seconds) my Onyx+ gets the red light issue. This is mostly a problem on custom scripts where the script is not yet finished but it can also happen with some SLR scripts.

I don’t think it’s a issue with my Onyx+ because again it works fine when there is action. It also has no issue with the slow parts so the motors do have enough strength to move. I use the max. interval length set to 800 in FunExpander to make sure that the max length between points is 800ms or less.

The movement when using HC does fee much better than SLRI (much smoother) but turning my Onyx off every few minutes is tiresome. I also have to quit the SLR app and open HC again because it won’t connect automatically if I reset my Onyx. Does anybody experience the same or a similar issue?

Hey @Rukker, I am one of the developers of SLR-i / HC. You are right that the setting for Onyx+ has changed. We use a different algorithm which helps with smoother movements (as you noticed).

Can you please try the Onyx+ boost setting maxed out at 100% to see what happens? Please let me know if you still get a red light.

If that helps then we might be able to tweak it further to prevent the red light while keeping the smoother movement.

1 Like

Ok thx, will try it out tonight

1 Like

I tried setting it to 100% and I still got the red light on parts with no action.

1 Like

@raser1 Is there anything more you need to know? If you can’t find the issue it would also be acceptable if you can make the HC app automatically reconnect to the Onyx+ while still in SLR if possible. After getting the red light I reboot the Onyx while still in SLR but it doesn’t reconnect to HC automatically. To make it connect to HC again I have to reboot the Onyx, exit SLR first and open the HC app.

Hey it’s strange that it doesn’t auto reconnect. I thought it should. :thinking:

We may add an option to switch back to the old algorithm for Onyx+, but this can take a while before it’s released.