Scriptplayer crash instantly - HELP!

Hi Guys,
Previously scriptplayer has always worked flawlessly for me, until I upgraded Windows 10 to Windows 11.
Now Scriptplayer runs, and it will play video, but the moment you try to connect to fleshlight, it instantly crashes to desktop. No error, nothing. Just dies. I’ve tried running with various compatability options, i’ve reinstalled it, I’ve used the latest debug version, nothing seems to fix it.
Has anyone else encountered this and found a fix?
Also, what alternatives are there for scriptplayer?

Fixed. My apologies. There was a replacement bluetooth driver for my motherboard, specifically for windows 11, and whilst I had grabbed it, the installer behaved oddly, in that it didn’t seem to do anything. It ran, but nothing was visible. I investigated this further and I think it may be partly to do with Windows 11’s version of defender, and system protections blocking things, which you can’t entirely disable. But I was able to disable them enough, and run a batch installer which succeeded in replacing the driver files. It would have been nice if Asus made this clear, but they did not. For anyone else having this issue, if you’re using an Asus board, i recommend you temporarily disable Windows Defender, and any of its components through Windows settings, and when you extract the driver files, instead of clicking the asussettup.exe, just use a terminal window, browse to the folder you extracted, and run the install.bat provided, which is what the Asussetup.exe was supposed to do but seems like it didn’t for me… anyway, you’ll see the output in the terminal as to it succeeding or not. Mine did, i restarted to be safe. Re-enabled Defender in all its glory, and ran scriptplayer, which now connects without crashing.

TL;DR It’s a bluetooth driver error in windows 11 since upgrading from windows 10. Go to your manufacturers website and find the w11 bluetooth driver for your board. If you have trouble installing it, see above.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.