EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

ScriptPlayer - Handy Crashes When Adjusting Stroke Length

I’m using ScriptPlayer 1.1.1, Windows 10, NET Framework 4.8, checked for updates, always running as Admin, and I’ve gone through all the settings. I start it up, everything works, then I click once either up or down on the stroke length, and then it crashes. This happens every single time without exception. The really strange thing is that this never happens on my other machine. It crashes alot on that one especially when doing something with playlists or playing a new video, but at least I can start it up again and it works. I even went through the settings side by side and made sure every little thing was the same even the stuff that shouldn’t even matter. I really don’t know what to try anymore. Can I get some help please?

1 Like

Try the latest beta. Version 1.1.1 is pretty outdated - new main release will be out when I’ve updated the Handy API to version 2 (Firmware 3).

2 Likes

I don’t think the ScriptPlayer setting does anything different from the “up” or “down” buttons on the Handy itself, have you tried using those?

@Liquid That worked! Thanks I just didn’t think to try the beta versions.

Am I correcting in understanding that nothing in the the Range settings works for the Handy right now?

@yoghfebba1 Yeah the controls work for that too. You can also use the control stroke sliders for the player on this app too https://virtual-blowjob.netlify.app/

Yes.

ScriptPlayer still uses the handy API v1, which only has a single setting for the range (starting at the very bottom) that can be controlled with the +/- buttons or on the device itself.

With API v2 and FW 3 the full range is supported and I will likely remove the buttons and use the range slider instead.

1 Like

Now I have another really weird problem.

I installed the beta version of ScriptPlayer, and everything was working great. Then one day it just stopped playing certain scripts. The title shows up at the very top of the player, but nothing happens. When I move the cursor over any of the buttons they turn black. I’m not certain exactly when this started happening, but I know it was around the time I loaded a very large folder into the playlist. Almost none of the scripts in that folder had thumbnails, heatmaps, and such so it started creating them. This takes up almost of my computer’s processing power. After a very long time of letting it run, I eventually wanted to play something but since there doesn’t seem to be a way to stop the process and not knowing what to do I opened up task manager and ended ffmpeg. So now it won’t play certain scripts, but the weird thing is it plays scripts that had been played before this event but not ones that hadn’t. Even the “new” scripts that have already had thumbnails and heatmaps don’t play. I’ve deleted ffmpeg and downloaded it again, I’ve done the same with the beta version of ScriptPlayer, and I’ve even tried the previous version of ScriptPlayer. I’m always running it as administrator and when I’ve uninstalled I’ve also deleted the app data.

Have you tried disabling the ‘automatically generate thumbnails etc’ settings in scriptplayer?

Yes and no change.

It’s gotten even stranger now. I just tried to add a new folder to the playlist. The folder is 1.5 gb and has nine videos. Added it and ScriptPlayer just closed right away. No hourglass or error message. Now when I try to open it, nothing happens. I get a brief hourglass and then nothing.

I got ScriptPlayer running again by deleting app data. It’s still got the strange behavior though. It seems as if ffmpeg won’t run anymore. I try to run it from task manager but nothing happens. When I try to generate anything from a file in the playlist that has something missing, it shows up in task manager only for a second. When I open the queue while trying to generate, it always says it failed for whatever’s missing. What is especially confusing is that it just won’t play certain files even if thumbnails and heatmaps have already been generated.

Does the ScriptPlayer path for ffmpeg.exe still exist? Did you happen to delete/move something?

The path is still there. I’ve even deleted it, downloaded again, and reinstalled. Same with ScriptPlayer. I’ve tried to just start from scratch as if none of it has ever existed on my computer, but every time after installation it does the same thing.

So here’s today’s update. I added the big folder that seems to have started it all back into the playlist. I thought maybe if it could finish generating then this could all be fixed. When I opened up the queue, it was in fact generating everything successfully. When I can back later, it appeared that my computer had shut down so I logged back in, opened ScriptPlayer, and now all I get is a white box that says ScriptPlayer at the top. I delete everything and then reinstall but it’s always just a white box. This is insane.

Just did a search for keyword “scriptplayer” on my computer, deleted every single result, rebooted, reinstalled, and it’s still not working. Just a white box with the word “ScriptPlayer” at the top.