EroScripts is a community for scripts that sync up interactive sex toys with porn. Learn more.

To discover, download, and help choose what gets scripted, create an account.

EroScripts

Scriptplayer not linking to Intiface

Hi. Please can someone help? I’ve downloaded Intiface and Scriptplayer on a Windows Laptop to control The Handy. When I first downloaded it it worked fine. I then shut down my laptop. When I started up again, Scriptplayer won’t link to Intiface. I haven’t changed any settings or anything else. I’ve tried downloading an alternative to Scriptplayer (Multifunplayer), but I can’t get that to work at all. Please can someone help? Why won’t Scriptplayer link to Intiface? What can I do to correct the issue? I’m not particularly techy, so laymans terms would be great. Thank you for your help.

This is assuming your Handy is configured, and can connect to your wifi, and you have the correct connection key

Check ScriptPlayer is configured correctly and you have the correct connection key entered under The Handy settings. Also to make things easy, make sure Script Host is handyfeeling.com. You can play with the Local Script host settings later after you get the thing working.

Plug in your Handy and get it into wifi mode.

Go back to ScriptPlayer and select “Connect to Handy directly” under the Devices drop down menu.

ScriptPlayer should tell you if it is able to connect to your Handy. You can also click “Show Devices” under the Devices menu to check what devices are connected. You may have “Connect to Handy directly” a couple more times if it didn’t connect the first time.

If this doesn’t work, restart your router and your computer and try again

Thanks for the reply. However, it’s the link between Scriptplayer and Intiface that isn’t working. Intiface links to the Handy fine.

My bad. Misread. I’m guessing you are trying to use The Handy in BT mode via buttplug. It can be a little tricky getting all the parts to work together. Be sure the server is started in Intiface, before trying to connect with ScriptPlayer. What are your Buttplug settings in ScriptPlayer?

I think the server in intiface is working before I connect to Scriptplayer, so I don’t think that’s it. What settings in Scriptplayer am I looking for, and what should they be if things are working correctly? As far as I can tell everything on Scriptplayer is on default settings.

When you start up Intiface, check server status and start server if it is not already running. In the settings you can select to have the server start when you start Intiface.

The SP settings you need to check under Buttplug. I believe default Web Sockets URL is “ws://localhost:12345/buttplug” You just want to make sure the port number matches with your Intiface setting for websocket port. The other settings are if you want SP to start Interface and auto search for devices on start up.

i have the same problem. scriptplayer wont connect to intiface. And Multifunplayer has some weird .sln ending so i cannot open it.

Edit: I found out the Problem with Scriptplayer i had. You have to start a Server with Intiface but not connect to the device yet… first connect Scriptplayer with intiface and then after that connect the device.