Scripts + SLR

Is there any way of incorporating downloaded scripts into SLR if I didn’t buy them direct from slr. Examples are scripts uploaded here that the vid is on slr. Right now I have to download the video and stream it that way as opposed to direct from slr.

Name the script the video number (found at the end of the URL).

1 Like

So if I have a script for this…

I’d just name the script 8796???
And I’d be able to stream the video from SLR?

Just rename the funscript to the number showed at the end of URL and put it in the “interactive” folder in the root of your headset (for standalone headsets).

Yep, name it 8796.funscript and put it in the folder on your device, it should work.

1 Like

Shit I had no idea you could do this. I always thought I had to have the file direct on my device or purchased through slr. This is awesome thanks guys.

It’s no secret, it’s even mentioned in their interactive toy guide. Not sure if it works with any device, but I tried in with Handy like a year ago and it worked as intended.

It works with any toy that works with SLR interactive.

So I tried it with this scene…

I downloaded the script from here…

renamed the file 21841, loaded into my interactive folder on my quest 2.
launched the video from slr, but it never found or even knew there was a script to play. Normally there’s the little “script” icon when i play teh video but it wasn’t there at all. Am I missing something?

You miss, that this particular scene has not been scripted yet, that’s why there is no icon :stuck_out_tongue:

1 Like

oooh i mean if i can use scripts i get from here and incorporate them into SLR :upside_down_face:

If i look at the URL, if you want to use a non-SLR implemented script, maybe if i look at the URL of the SLR vid:

you can try rename the .funscript in “from-the-vault-how-to-wash-your-car-right-21841.funscript” and try it again

No, if you want to use that one, you name it 21841.funscript and put it in your interactives folder. That should just do the trick.

Only things I can think of that might be causing problems is if you accidentally deleted .funscript, misclicked it into the wrong folder, or got the name wrong. If rechecking all that doesn’t show the problem, I’d try restarting your headset if you haven’t. But realistically based on what you’ve said I think it should just be working already.

(Oh, also make sure the toy in question is actually on and connected. The icon doesn’t appear if it isn’t.)

1 Like

alright ill double check those things, thanks!

As we don’t know how your setup is like:

SLR Support says exactly:

Local folder Script Support

  • Simply rename the script to the Script ID of the scene - for ex = 15547.funscript for 15479.funscript for the Hard Sell VR video (ID is also shown in player panel in SLR app and address bar in a browser)
  • Place the script file into “Interactive” folder in root on Android devices or in VR Headset onboard storage for Oculus Go/Quest, OR the “Documents” folder on Windows

So if you use your headset on a windows PC the funscript should be stored in the “documents” folder…

Hey, do you have a script for this video? Or were you speaking hypothetically?

It’s here: WankzVR - Ella Reese, Lacy Lennon, Nikki Peach - Star-Spangled Banger – RealSync

Legend. Thank you!